cancel
Showing results for 
Search instead for 
Did you mean: 
yoann63
Level 7

error http 500 every reboot of the server

Jump to solution

Hi,

i have always the same problem when i reboot my server (ex: applying hotfix windows, event when i make a reboot without changing anything else)

The connection is always unavailable.

I had to restart the

Services Serveur d'applications McAfee ePolicy Orchestrator 4.6.2 (Although it is already started).

Then the server is up.

When i take a look of these services, they are already started:

- Serveur d'applications McAfee ePolicy Orchestrator 4.6.2 --> started

- Serveur McAfee ePolicy Orchestrator 4.6.2 --> started

- Analyseur d'événements McAfee ePolicy Orchestrator 4.6.2 --> started

- SQL Server (SQLEXPRESS) --> started

- SQL Server Browser --> started

- SQL Server VSS Writer --> started

My conf is windows server 2008R2, EPO 4.6.2, SQL Server express 2008

I tested my db conf with https://localhost:8443/core/config. Connection test is ok.

Has anybody met this problem ?

Thanks

Yoann

0 Kudos
1 Solution

Accepted Solutions
ulyses31
Level 16

Re: error http 500 every reboot of the server

Jump to solution

Perhaps the problem isdue by other services starting during reboot that causes the "Serveur d'applications McAfee ePolicy Orchestrator 4.6.2" service to be unstable or not really started (even if appearing as started).

If you set them to be started manually and start them once you log into the server does it works? If so you may try to delay ePO's service start and see if it works (http://support.microsoft.com/kb/193888)

Edit: Under Windows 2008 you have another method to delay service start: http://www.techrepublic.com/blog/datacenter/delayed-start-feature-increases-options-for-windows-serv...

El mensaje fue editado por: ulyses31 on 14/01/13 15:33:20 CET
0 Kudos
10 Replies
McAfee Employee

Re: error http 500 every reboot of the server

Jump to solution

Check the server.log, orion.log and Windows event logs - are there any errors at startup?

HTH -

Joe

0 Kudos
yoann63
Level 7

Re: error http 500 every reboot of the server

Jump to solution

hi,

so,

in the windows logs:

-MSSQLServerADHelper100 : '0' is an invalid number of start up parameters. This service takes two start up parameters.(but i didn't see this error every reboot)

- Apache Service:

The Apache service named  reported the following error:

>>> [Thu Jan 10 16:42:26 2013] [notice] Disabled use of AcceptEx() WinSock2 API     . (the same)

that's all for windows.

in: C:\Program Files (x86)\McAfee\ePolicy Orchestrator\Server\Logs\orion.log:

2013-01-10 16:45:12,338 WARN  [http-8444-Processor24] server.OrionLoginModule  - Root cause of LoginException

org.springframework.beans.factory.BeanCreationException: Bean factory is shut down

    at com.mcafee.orion.core.spring.MultiParentBeanFactory.checkEnabled(MultiParentBeanFactory.java:382)

    at com.mcafee.orion.core.spring.MultiParentBeanFactory.getBean(MultiParentBeanFactory.java:180)

    at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:160)

    at com.mcafee.orion.core.OrionCore.getUserLoader(OrionCore.java:110)

    at com.mcafee.orion.core.server.OrionLoginModule.getUserLoader(OrionLoginModule.java:632)

    at com.mcafee.orion.core.server.OrionLoginModule.authenticate(OrionLoginModule.java:229)

    at com.mcafee.orion.core.server.OrionLoginModule.login(OrionLoginModule.java:106)

    at sun.reflect.GeneratedMethodAccessor80.invoke(Unknown Source)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

    at java.lang.reflect.Method.invoke(Method.java:597)

    at javax.security.auth.login.LoginContext.invoke(LoginContext.java:769)

    at javax.security.auth.login.LoginContext.access$000(LoginContext.java:186)

    at javax.security.auth.login.LoginContext$4.run(LoginContext.java:683)

    at java.security.AccessController.doPrivileged(Native Method)

    at javax.security.auth.login.LoginContext.invokePriv(LoginContext.java:680)

    at javax.security.auth.login.LoginContext.login(LoginContext.java:579)

    at org.apache.catalina.realm.JAASRealm.authenticate(JAASRealm.java:401)

    at org.apache.catalina.realm.JAASRealm.authenticate(JAASRealm.java:326)

    at org.apache.catalina.authenticator.BasicAuthenticator.authenticate(BasicAuthenticator.java:181)

    at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:528)

    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)

    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)

    at com.mcafee.orion.core.server.AjaxValve.invoke(AjaxValve.java:84)

    at com.mcafee.orion.core.server.OrionUserSetupValve.invoke(OrionUserSetupValve.java:41)

    at org.apache.catalina.authenticator.SingleSignOn.invoke(SingleSignOn.java:393)

    at com.mcafee.orion.core.server.OrionSingleSignOn.invoke(OrionSingleSignOn.java:141)

    at com.mcafee.orion.core.server.ClientCertValve.invoke(ClientCertValve.java:69)

    at com.mcafee.orion.core.server.ClientCertValve.invoke(ClientCertValve.java:69)

    at com.mcafee.orion.core.server.ParameterEncodingValve.invoke(ParameterEncodingValve.java:37)

    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)

    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:174)

    at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:879)

    at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665)

    at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528)

    at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81)

    at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)

    at java.lang.Thread.run(Thread.java:619)

in: C:\Program Files (x86)\McAfee\ePolicy Orchestrator\DB\Logs\server.log:

Rejecting agent due to an invalid or duplicate sequence number

20130110165238    E    #00548    NAIMSRV     Failed to process agent request

Et je précise qu'après un redémarrage manuel des services l'accès web est de nouveau fonctionnel.

Merci de votre aide.

Yoann

0 Kudos
ulyses31
Level 16

Re: error http 500 every reboot of the server

Jump to solution

when you look at ePO services (when you can't access web console) does the "Services Serveur d'applications McAfee ePolicy Orchestrator 4.6.2" service really appear as "started" or could it be stuck at "starting"?

0 Kudos
yoann63
Level 7

Re: error http 500 every reboot of the server

Jump to solution

i'm checking...

0 Kudos
yoann63
Level 7

Re: error http 500 every reboot of the server

Jump to solution

i confirm: it's written "started"

i just try with an other browser: chrome (which i don't use usually with epo) and i obtain: An unexpected error occurred while trying to handle your request.


0 Kudos
ulyses31
Level 16

Re: error http 500 every reboot of the server

Jump to solution

Can you see if there's another tomcat installation on this server under add/remove software? (for example having tomcat 6)

0 Kudos
yoann63
Level 7

Re: error http 500 every reboot of the server

Jump to solution

no tomcat installation...

0 Kudos
ulyses31
Level 16

Re: error http 500 every reboot of the server

Jump to solution

Perhaps the problem isdue by other services starting during reboot that causes the "Serveur d'applications McAfee ePolicy Orchestrator 4.6.2" service to be unstable or not really started (even if appearing as started).

If you set them to be started manually and start them once you log into the server does it works? If so you may try to delay ePO's service start and see if it works (http://support.microsoft.com/kb/193888)

Edit: Under Windows 2008 you have another method to delay service start: http://www.techrepublic.com/blog/datacenter/delayed-start-feature-increases-options-for-windows-serv...

El mensaje fue editado por: ulyses31 on 14/01/13 15:33:20 CET
0 Kudos
yoann63
Level 7

Re: error http 500 every reboot of the server

Jump to solution

Great...

It seems to work...

FYI:

i had to add start delay for following services:

- MCAFEEEVENTPARSERSRV

- MCAFEETOMCATSRV250

- MCAFEEAPACHESRV

- MSSQL$SQLEXPRESS

- SQLBrowser

Thanks for your help

0 Kudos