cancel
Showing results for 
Search instead for 
Did you mean: 
mcdave
Level 10
Report Inappropriate Content
Message 1 of 19

epo 4.5 webconsole endlessly loading

Hi,

We regulary strugling with the webconsole of our eposerver (V4.5 +Patch1).

Every 2 or 3 days we get the animated "* McAfee" loading logo and it seems to be stuck there (the logon screen doesn't appear)

Sometime resetting the services:
"McAfee ePolicy Orchestrator 4.5.0 Application Server"

"McAfee ePolicy Orchestrator 4.5.0 Event Parser"

"McAfee ePolicy Orchestrator 4.5.0 Server"

fix the problem but not always, if this fails we have to reboot the server (and wait at least 5 minutes after the reboot) to get it work again.

I also don't see any CPU overload during the issue.

I really don't like the resetting & rebooting solution so here is my question.
Does anyone an idea what could cause this and how to solve this.

regards

Dave

18 Replies
Highlighted
d0x
Level 7
Report Inappropriate Content
Message 2 of 19

Re: epo 4.5 webconsole endlessly loading

Have a look at your apache logs, surely there must be something amiss. Only had a similar problem once, when the database server went offline.

on 7/9/10 6:12:47 AM CDT

Re: epo 4.5 webconsole endlessly loading

Does this happen when you provide your username and credentials or just when you try to bring up the ePO console?

- Amiya

mcdave
Level 10
Report Inappropriate Content
Message 4 of 19

Re: epo 4.5 webconsole endlessly loading

When I try to bring up the ePO console.

tonyb99
Level 13
Report Inappropriate Content
Message 5 of 19

Re: epo 4.5 webconsole endlessly loading

You get the same issue when trying to connect to the web interface from a standard pc rather than on the epo server?

What entries are you getting in EpoApSvr.log at the time this happens

mcdave
Level 10
Report Inappropriate Content
Message 6 of 19

Re: epo 4.5 webconsole endlessly loading

It occurs from both the eposerver & standard PCs.

I'll keep an eye on EpoApSvr.log the next time it happens. (the info in the log is all fresher than the last occurance)

regards

Dave

mcdave
Level 10
Report Inappropriate Content
Message 7 of 19

Re: epo 4.5 webconsole endlessly loading

It's happening again right now (several minutes to log on).

Here is a part of the EpoApSvr.log file:

20100817111349    I    #1496    naInet      HTTP Session closed
20100817111349    I    #1496    naInet      ------------------------------------------------------------
20100817111349    I    #1496    SIM_InetMgr    Session 1 ended, result=1
20100817111349    I    #1496    SiteMgr     GeneralInetRequestThreadProc: GeneralInetRequest thread ended
20100817111349    x    #1496    SiteMgr     SiteMgr main control final release...
20100817111349    I    #1496    SiteMgrWrap    Created instance of Site Manager
20100817111349    I    #1496    SiteMgr     SetEPOMode: SiteMgr enter ePO mode, server=EPOSRV-01, port=8095, EPOUser=, Password=********
20100817111349    I    #1496    SiteMgr     DALInit: Connected to DAL successful
20100817111349    I    #1496    SiteMgr     SetEPOMode: Set ePO mode successful
20100817111349    I    #1496    SiteMgr     GeneralInetRequestThreadProc: GeneralInetRequest thread started
20100817111349    I    #1496    SIM_InetMgr    Starting download session for url myavert.avertlabs.com:8801
20100817111350    I    #1496    naInet      HTTP Session initialized
20100817111350    I    #1496    naInet      Connecting to HTTP Server using Microsoft WinInet
20100817111350    I    #1496    naInet      Trying to connect to Proxy Server proxy.eu.com:80 using INTERNET_OPEN_TYPE_PROXY
20100817111350    I    #1496    naInet      Connected to Server: myavert.avertlabs.com on Port: 8801 using WinInet
20100817111350    I    #1496    SIM_InetMgr    Started download session 1 for site myavert.avertlabs.com:8801
20100817111350    I    #1496    SiteMgr     GeneralInetRequestThreadProc: Downloading /reportservice.asmx
20100817111350    I    #1496    SIM_InetMgr    Downloading file reportservice.asmx from session 1, LocalDir=C:\WINDOWS\TEMP\nai746E.tmp\00000000, RemoteDir=
20100817111350    I    #1496    naInet      Open URL: http://myavert.avertlabs.com:8801/reportservice.asmx
20100817111350    I    #1496    naInet      Trying to download using Microsoft WinInet library
20100817111350    I    #1496    naInet      Conneting to Proxy Server proxy.eu.com:80 using INTERNET_OPEN_TYPE_PROXY
20100817111350    I    #1496    naInet      No resume download needed, calling InternetOpenUrl
20100817111350    I    #1496    naInet      Downloading a file of total size: 973, content-length: 973
20100817111350    I    #1496    naInet      Downloaded 973 bytes this time
20100817111350    I    #1496    naInet      Downloaded 0 bytes this time
20100817111350    I    #1496    SIM_InetMgr    Downloaded file reportservice.asmx successfully in session 1
20100817111350    I    #1496    naInet      HTTP Session closed
20100817111350    I    #1496    naInet      ------------------------------------------------------------
20100817111350    I    #1496    SIM_InetMgr    Session 1 ended, result=1
20100817111350    I    #1496    SiteMgr     GeneralInetRequestThreadProc: GeneralInetRequest thread ended
20100817111350    x    #1496    SiteMgr     SiteMgr main control final release...
20100817112631    I    #3012    EPOJNI      Getting license data...
20100817112648    I    #3012    EPOJNI      Getting license data...
20100817112731    I    #3024    EPOJNI      Getting license data...
20100817113025    I    #1496    SiteMgrWrap    Created instance of Site Manager
20100817113054    I    #1496    SiteMgr     SetEPOMode: SiteMgr enter ePO mode, server=EPOSRV-01, port=8095, EPOUser=, Password=********
20100817113054    I    #1496    SiteMgr     DALInit: Connected to DAL successful
20100817113123    I    #1496    SiteMgr     SetEPOMode: Set ePO mode successful
20100817113123    I    #1496    SiteMgr     GeneralInetRequestThreadProc: GeneralInetRequest thread started
20100817113123    I    #1496    SIM_InetMgr    Starting download session for url myavert.avertlabs.com:8801
20100817113150    I    #1496    naInet      HTTP Session initialized
20100817113150    I    #1496    naInet      Connecting to HTTP Server using Microsoft WinInet
20100817113150    I    #1496    naInet      Trying to connect to Proxy Server proxy.eu.com:80 using INTERNET_OPEN_TYPE_PROXY
20100817113150    I    #1496    naInet      Connected to Server: myavert.avertlabs.com on Port: 8801 using WinInet
20100817113150    I    #1496    SIM_InetMgr    Started download session 1 for site myavert.avertlabs.com:8801
20100817113150    I    #1496    SiteMgr     GeneralInetRequestThreadProc: Downloading /reportservice.asmx
20100817113150    I    #1496    SIM_InetMgr    Downloading file reportservice.asmx from session 1, LocalDir=C:\WINDOWS\TEMP\nai7474.tmp\00000000, RemoteDir=
20100817113150    I    #1496    naInet      Open URL: http://myavert.avertlabs.com:8801/reportservice.asmx
20100817113150    I    #1496    naInet      Trying to download using Microsoft WinInet library
20100817113150    I    #1496    naInet      Conneting to Proxy Server proxy.eu.com:80 using INTERNET_OPEN_TYPE_PROXY
20100817113150    I    #1496    naInet      No resume download needed, calling InternetOpenUrl
20100817113150    I    #1496    NAINET      Resolving name proxy.eu.com to address
20100817113150    I    #1496    NAINET      Name resolved to 10.1.x.x
20100817113151    I    #1496    naInet      Downloading a file of total size: 8047, content-length: 8047
20100817113151    I    #1496    naInet      Downloaded 8047 bytes this time
20100817113151    I    #1496    naInet      Downloaded 0 bytes this time
20100817113151    I    #1496    SIM_InetMgr    Downloaded file reportservice.asmx successfully in session 1
20100817113151    I    #1496    naInet      HTTP Session closed
20100817113151    I    #1496    naInet      ------------------------------------------------------------
20100817113151    I    #1496    SIM_InetMgr    Session 1 ended, result=1
20100817113151    I    #1496    SiteMgr     GeneralInetRequestThreadProc: GeneralInetRequest thread ended
20100817113151    x    #1496    SiteMgr     SiteMgr main control final release...

I hope this contains enough info to find the problem source.

(It looks like getting the license data is taking ages)

thx in adv.

tonyb99
Level 13
Report Inappropriate Content
Message 8 of 19

Re: epo 4.5 webconsole endlessly loading

maybe its worth logging a support call to find out the address of the licence server so you can check connectivity through to it, maybe an exception under you firewall rules to it

McAfee Employee JoeBidgood
McAfee Employee
Report Inappropriate Content
Message 9 of 19

Re: epo 4.5 webconsole endlessly loading

This is likely to be a red herring - it's unlikely that the epoapsrv log is going to be relevant for this kind of issue, I'm afraid

Instead you need to be looking at the server.log and orion.log at the time that the problem occurs - are there any errors in there? For example max connections reached, or anything like that?

Also - check the SQL server logs for any anomalies, as a failure to communicate with SQL can cause symptoms like this.

HTH -

Joe

mcdave
Level 10
Report Inappropriate Content
Message 10 of 19

Re: epo 4.5 webconsole endlessly loading

Here it is again the endless loading issue.


I've checked the orion.log & server.log but nothing odd in there especially no max connection issues.

I'm going to reboot the server again, because I've need it urgently

I'll try to check the SQL logs later.

Update:

- Issue returned again (2nd time today) but this time a reboot didn't help and it got worse.
Now I don't even get the login prompt anymore.

Here is a piece from the orion.log:

2010-09-06 15:16:41,572 ERROR [http-8096-Processor24] [/dcRedirect].[dcRedirect]  - Servlet.service() for servlet dcRedirect threw exception
org.springframework.beans.factory.NoSuchBeanDefinitionException: No bean named 'epo.dataChannel.action' is defined
    at org.springframework.beans.factory.support.DefaultListableBeanFactory.getBeanDefinition(DefaultListableBeanFactory.java:356)
    at com.mcafee.orion.core.spring.MultiParentBeanFactory.getMergedBeanDefinition(MultiParentBeanFactory.java:349)
    at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:243)
    at com.mcafee.orion.core.spring.MultiParentBeanFactory.getBean(MultiParentBeanFactory.java:187)
    at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:160)
    at com.mcafee.epo.dataChannel.servlet.EPODataChannelServlet.doPost(EPODataChannelServlet.java:68)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:647)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
    at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:679)
    at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:461)
    at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:399)
    at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:301)
    at com.mcafee.epo.dataChannel.servlet.EPODataChannelRedirectServlet.doPost(EPODataChannelRedirectServlet.java:68)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:647)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
    at org.apache.catalina.valves.FastCommonAccessLogValve.invoke(FastCommonAccessLogValve.java:482)
    at com.mcafee.orion.core.server.AjaxValve.invoke(AjaxValve.java:88)
    at com.mcafee.orion.core.server.OrionUserSetupValve.invoke(OrionUserSetupValve.java:43)
    at org.apache.catalina.authenticator.SingleSignOn.invoke(SingleSignOn.java:393)
    at com.mcafee.orion.core.server.OrionSingleSignOn.invoke(OrionSingleSignOn.java:113)
    at com.mcafee.orion.core.server.ParameterEncodingValve.invoke(ParameterEncodingValve.java:37)
    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:174)
    at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:875)
    at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665)
    at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528)
    at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81)
    at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)
    at java.lang.Thread.run(Thread.java:619)

I now see several "Server is too busy (245 connections) to process request" messages in the server.log

here is a part of the log just before & after a reboot:

20100906150721    E    #4040    mod_epo     Server is too busy (245 connections) to process request
20100906150721    I    #3380    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx.253.70
20100906150721    I    #3380    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx.254.187
20100906150721    I    #3380    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx.253.183
20100906150721    I    #3380    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx.15.33
20100906150721    I    #3380    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx.253.54
20100906150721    I    #3380    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx.15.86
20100906150721    I    #3380    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx.21.26
20100906150721    I    #3380    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx.20.50
20100906150721    I    #3380    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx.253.240
20100906150721    I    #4040    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx.254.191
20100906150721    I    #3856    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx.15.42
20100906150721    I    #3856    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx.5.144
20100906150721    I    #3856    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx.253.119
20100906150909    I    #2156    NAISIGN     Loading fips module, current folder: C:\Program Files\McAfee\ePolicy Orchestrator\Apache2
20100906150909    I    #2156    NAISIGN     Checking for fips module in c:\PROGRA~1\McAfee\EPOLIC~1
20100906150909    I    #2156    NAISIGN     Found fips module: c:\PROGRA~1\McAfee\EPOLIC~1\cryptocme2.dll
20100906150912    I    #2156    NAISIGN     FIPS library initialized successfully
20100906150914    I    #2156    RULEENG     Starting EPO RuleEngine
20100906150914    I    #2156    NAISIGN     Loading fips module, current folder: c:\PROGRA~1\McAfee\EPOLIC~1
20100906150914    I    #2156    NAISIGN     Checking for fips module in c:\PROGRA~1\McAfee\EPOLIC~1
20100906150914    I    #2156    NAISIGN     Found fips module: c:\PROGRA~1\McAfee\EPOLIC~1\cryptocme2.dll
20100906150914    I    #2156    NAISIGN     FIPS library initialized successfully
20100906150915    I    #2156    NAIMSRV     Initializing server...
20100906150915    I    #2156    NAIMSRV     Initializing DAL Connection Pool...
20100906150915    I    #2156    NAIMSRV     DAL Connection Pool Initialized.
20100906150926    I    #2156    NAISIGN     Loading fips module, current folder: c:\PROGRA~1\McAfee\EPOLIC~1
20100906150926    I    #2156    NAISIGN     Checking for fips module in c:\PROGRA~1\McAfee\EPOLIC~1
20100906150926    I    #2156    NAISIGN     Found fips module: c:\PROGRA~1\McAfee\EPOLIC~1\cryptocme2.dll
20100906150927    I    #2156    NAISIGN     FIPS library initialized successfully
20100906151107    I    #2156    NAIMSRV     Server state at startup: Enabled
20100906151132    I    #2156    MCUPLOAD    Successfully disabled CA trust options.
20100906151145    E    #2156    MCUPLOAD    Failed to process the secure communication request.  Error=401
20100906151156    I    #2156    MCUPLOAD    Successfully disabled CA trust options.
20100906151223    I    #2156    MCUPLOAD    Successfully disabled CA trust options.
20100906151239    I    #2156    MCUPLOAD    Successfully disabled CA trust options.
20100906151259    I    #2156    MCUPLOAD    Successfully disabled CA trust options.
20100906151326    I    #2156    MCUPLOAD    Successfully disabled CA trust options.
20100906151402    I    #2156    MCUPLOAD    Successfully disabled CA trust options.
20100906151903    E    #2156    MCUPLOAD    Failed to receive http response
20100906151903    E    #2156    MCUPLOAD    Failed to process the secure communication request.  Error=The system cannot find the file specified.
20100906151914    I    #2156    MCUPLOAD    Successfully disabled CA trust options.
20100906152415    E    #2156    MCUPLOAD    Failed to receive http response
20100906152415    E    #2156    MCUPLOAD    Failed to process the secure communication request.  Error=The system cannot find the file specified.
20100906152425    I    #2156    MCUPLOAD    Successfully disabled CA trust options.
20100906152928    E    #2156    MCUPLOAD    Failed to receive http response
20100906152928    E    #2156    MCUPLOAD    Failed to process the secure communication request.  Error=The system cannot find the file specified.
20100906152938    I    #2156    MCUPLOAD    Successfully disabled CA trust options.
20100906153440    E    #2156    MCUPLOAD    Failed to receive http response
20100906153440    E    #2156    MCUPLOAD    Failed to process the secure communication request.  Error=The system cannot find the file specified.
20100906153450    I    #2156    MCUPLOAD    Successfully disabled CA trust options.
20100906153951    E    #2156    MCUPLOAD    Failed to receive http response
20100906153951    E    #2156    MCUPLOAD    Failed to process the secure communication request.  Error=The system cannot find the file specified.
20100906154001    I    #2156    MCUPLOAD    Successfully disabled CA trust options.
20100906154502    E    #2156    MCUPLOAD    Failed to receive http response
20100906154502    E    #2156    MCUPLOAD    Failed to process the secure communication request.  Error=The system cannot find the file specified.
20100906154512    I    #2156    NAIMSRV     Failed to connect to the ePO server.  The Agent Handler does not require the ePO server to be running, but it will exchange information if it is running.
20100906154542    I    #2156    NAIMSRV     Syncing keys with the ePO server 'OUR_POSERVER'.
20100906154542    I    #2156    MCUPLOAD    Successfully disabled CA trust options.
20100906155043    E    #2156    MCUPLOAD    Failed to receive http response
20100906155043    E    #2156    MCUPLOAD    Failed to process the secure communication request.  Error=The system cannot find the file specified.
20100906155043    E    #2156    NAIMSRV     Received an error from the server.  Error=2.
20100906155153    I    #2156    NAIMSRV     ePolicy Orchestrator server started.
20100906155153    I    #3160    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx.116.207
..
20100906155329    I    #3772    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx..7.80
20100906155330    E    #3708    mod_epo     Server is too busy (245 connections) to process request
20100906155330    E    #1124    mod_epo     Server is too busy (245 connections) to process request
20100906155330    E    #3708    mod_epo     Server is too busy (245 connections) to process request
20100906155330    I    #0288    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx..6.91
20100906155330    I    #3708    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx..6.91
20100906155330    I    #3708    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx..5.103
20100906155330    I    #3708    mod_eporepo    Received request, uri=/Software/SiteStat.xml, remoteIP=xx.xx..253.89

regards

Dave

Message was edited by: mcdave on 06/09/10 09:05:04 CDT
More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community