cancel
Showing results for 
Search instead for 
Did you mean: 
fafujay
Level 7
Report Inappropriate Content
Message 1 of 11

epo 4.0 software menu tab missing

i want some assistant in fixing this problem.  the menu items on my epo dashboard is missing the software tab.  How can I go about solving this?  Also am having errors like:

scp - Dependency RepositoryMgmt had initialization error
aramid - Dependency RepositoryMgmt had initialization error
EPOAGENTMETA - Dependency RepositoryMgmt had initialization error
RepositoryMgmt-


Thanks in advance

fafujay

10 Replies
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 11

Re: epo 4.0 software menu tab missing

The RepositoryMgmt is a system extension and needs to be running before you can view the repository contents / Software tab. It looks like that extension is broken in your case. Were they are any changes done before this issue started  (for e.g. patch installation or unexpected server shutdown)?

fafujay
Level 7
Report Inappropriate Content
Message 3 of 11

Re: epo 4.0 software menu tab missing

Yes I did have unexpected server shutdown.  Any guide on how to fix that would be greatly welcome.

thanks

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 11

Re: epo 4.0 software menu tab missing

Since this is a system extension, there is possibly little that you can do other than reinstall ePO and restore from a recent backup of the database and keystore files.(refer to the Disaster Recovery KB51438)

If you are feeling adventurous, then try the steps below:

Do a fresh  install of ePO on a differnt system and bring it to the same patch level as your existing system.

Stop the epo services on both the old and new installations. Rename the RepositoryMgmt folder on the old system (RepositoryMgmt folder is under Program Files\McAfee\ePolicy Orchestrator\Server\Extensions\Installed folder)

Now copy the RepositoryMgmt folder from the new system to the old system.

Restart the ePO services on the old system and check if the error goes away.

Above steps assume that its only the files which may have gone bad - if more is involved then it may not work.

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 11

Re: epo 4.0 software menu tab missing

The errors you have listed are typically caused by conflicting encryption keys. See KB65477:

https://kc.mcafee.com/corporate/index?page=content&id=KB65477

The article above lists Dameware as the culprit although any software that uses the same encryption keys as we do could cause the same issue. I usually do this to identify the problem:

  1. Start | Run | msinfo32
  2. Expand Software Environment
  3. Select Loaded Modules
  4. Look at all instances of cryptocme2in the list. If you see that module running out of any non-mcafee directory (usually c:\windows\system32) that is most likely the culprit.

I hope that helps!

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 11

Re: epo 4.0 software menu tab missing

Good find...I should remember to search next time

fafujay
Level 7
Report Inappropriate Content
Message 7 of 11

Re: epo 4.0 software menu tab missing

yes, this is true. there is one cryptocme2 with the directory d:\windows\system32\cryptocme2.dll

how do I put this in the correct directory?

greatly appreciate your cotributions

thanks in advance

Fafujay

Reiner
Level 10
Report Inappropriate Content
Message 8 of 11

Re: epo 4.0 software menu tab missing

Hi Fafa,

Have you tried the workaround in the doc:

Rename cryptocme2.dll.

  1. Launch Windows Explorer and navigate to c:\Windows\system32 folder.
  2. Right-click cryptocme2.dll and select  Rename. Rename the file to cryptocme2.mfe.
  3. Restart your computer.
  4. Log on to the ePO Console.


Reiner

fafujay
Level 7
Report Inappropriate Content
Message 9 of 11

Re: epo 4.0 software menu tab missing

I am thrilled.  thank you very much.  the menu tab is back in action and no more error messages at log on. I am currently updating my repository.

great help

thanks

Fafujay

Reiner
Level 10
Report Inappropriate Content
Message 10 of 11

Re: epo 4.0 software menu tab missing

Good stuff!!! Have a Happy New Year!!

Reiner