cancel
Showing results for 
Search instead for 
Did you mean: 

ePolicy orchestrator patch 4

Hi to all

I have a strange problem installing on my server the epolicy orchestrator patch 4. The installation starts and goes without problems untill the end, when the system says that is impossible to install the patch, and all the system returns to the previous state. In order to understand the problem, i copy here the log:

EPO400-Error.Ini

[ErrorLog]
ErrorString=FAILURE: In LaunchAppAndWait while trying to run the following program:
"C:\PROGRA~1\McAfee\EPOLIC~1\jre\bin\java.exe"

Return code: 1
Error Message: Incorrect function.

"C:\PROGRA~1\McAfee\EPOLIC~1\jre\bin\java.exe"

Return code: 1
Error Message: Incorrect function.

Any idea?

Thanks
11 Replies
Pitch
Level 7
Report Inappropriate Content
Message 2 of 12

RE: ePolicy orchestrator patch 4

Update your jabva pack ?

RE: ePolicy orchestrator patch 4

I have upgraded another epo server with the same version of java, and the patch is installed without problems....
Pitch
Level 7
Report Inappropriate Content
Message 4 of 12

RE: ePolicy orchestrator patch 4

The problem is that your jre is not well installed because the program has errors in the functions : they could be half-written or some (class)files could be absent Smiley Wink

Reinstall your jre grin

RE: ePolicy orchestrator patch 4

I tried to reinstall java in different versions, and then to reinstall the patch 4, but nothing changes....
Pitch
Level 7
Report Inappropriate Content
Message 6 of 12

RE: ePolicy orchestrator patch 4

Did you go on this repertory and find the files named "java.exe" with an orange logo ?

RE: ePolicy orchestrator patch 4

Yes, the java.exe is like you say, and the error, posted in the core-patch.log is:

BUILD FAILED
C:\Program Files\McAfee\ePolicy Orchestrator\Installer\core\build.xml:444: java.sql.SQLException: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection.


Bye

RE: ePolicy orchestrator patch 4

RE: ePolicy orchestrator patch 4

I tried to set the user with NT authentication, posting the password, as the article says, and then to reinstall the patch, but the problem is the the same.....

RE: ePolicy orchestrator patch 4

This is McAfee's suggestion. Havent tried it yet though.

Cause
---------------
Microsoft SQL Server service is causing the installation to fail.

Solution
--------------------
Restart the Microsoft SQL Server service.

1) Log on to the SQL Server hosting the ePolicy orchestrator (ePO) database.

2) Click Start, Run, type services.msc, then click OK.

3) Right-click on the SQL Server [EPOSERVER] service and select Restart.

4) Verify it is possible to connect to the SQL server to access the ePO database using OSQL commands. For more information see KB51855 .

5) Try the patch installation again.