cancel
Showing results for 
Search instead for 
Did you mean: 
notime
Level 10
Report Inappropriate Content
Message 1 of 5

ePo server is busy

Hi all,

we were using ePO 3.6.1 and we face a probelm iv the McAfee Agent deplyment on one server as the follwing pic :

yesterday we upgrade ePO to 4.0 patch 3 but still facing same bropelm


we are using McAfee agent 4.0 patch 1, and i face same probelm in another account


any idea about this probelm, is it in MA 4 ???







machine log


2009-02-27 11:58:26 X #936 naInet Socket created, Handle 1172
2009-02-27 11:58:26 I #936 naInet Connecting to Real Server: 172.21.13.25 on port: 80
2009-02-27 11:58:26 I #936 naInet Connected to ePO Server: 172.21.13.25
2009-02-27 11:58:26 I #936 naInet Uploading SPIPE HTTP header
2009-02-27 11:58:26 I #936 naInet Uploading data in bytes: 798
2009-02-27 11:58:26 X #936 improgr ImProgress::operator()
2009-02-27 11:58:26 I #936 naInet Reading acknowledgement from ePO Server
2009-02-27 11:58:28 I #936 naInet HTTP return code: HTTP/1.1 503 Service Unavailable

2009-02-27 11:58:28 I #936 naInet
2009-02-27 11:58:28 I #936 naInet ePO Server is busy and not accepting anymore connections
2009-02-27 11:58:28 I #936 naInet Received response [503 Server Busy] from ePO Server
2009-02-27 11:58:28 I #936 naihttp failed to receive package..server is busy
2009-02-27 11:58:28 X #936 naInet Socket getting closed, Handle 1172
2009-02-27 11:58:28 I #936 naInet Uploaded file : C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack\pkg00128801951066870000_8137.spkg to Server successfully
2009-02-27 11:58:28 X #936 improgr ImProgress::operator()
2009-02-27 11:58:28 X #936 improgr ImProgress::operator()
2009-02-27 11:58:28 I #936 imsite NaInet library returned code == 12
2009-02-27 11:58:28 X #936 imutils getErrorText()
2009-02-27 11:58:28 X #936 imsite The naInet library returned a status code. [Parent error: NaInet library returned code == 12]
2009-02-27 11:58:28 X #936 naInet Socket getting closed, Handle -1
2009-02-27 11:58:28 I #936 naInet HTTP Session closed
2009-02-27 11:58:28 i #936 Agent ePO Server is busy
2009-02-27 11:58:28 i #936 Agent Agent communication session closed
2009-02-27 11:58:28 X #936 Filer GetFileAttributes,C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack\pkg00128801951066870000_8137.spkg
2009-02-27 11:58:28 X #936 Filer =32
2009-02-27 11:58:28 X #936 Filer SetFileAttributes,C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack\pkg00128801951066870000_8137.spkg
2009-02-27 11:58:28 X #936 Filer DeleteFile,C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack\pkg00128801951066870000_8137.spkg
2009-02-27 11:58:28 I #936 Agent Agent communication failed, result=-2403
2009-02-27 11:58:28 I #936 Agent Exponential retry in 1014 seconds, error=-2403(Server busy or reaches max concurrent download number)
2009-02-27 11:58:28 i #936 Agent Agent will connect to the ePO Server in 16 minutes and 54 seconds.
4 Replies

RE: ePo server is busy

Interesting, that I have also discovered the same issue with some of my clients.

I haven't got time to dig into the problem but I can say that we're using the same config like you.

ePO 4.0P3, MA 4.0P1, about 900 clients

Anyone else noticed the issue?

Edit: restarted services and everything is working as expected. However it's quite strange issue. Also noticed that most of the queries didn't produce any results.
msonen
Level 7
Report Inappropriate Content
Message 3 of 5

EPO Server busy...

I am also seeing these in my log..
I am not able to push any policy updates to my clients. I think it might be a port conflict. I'm not sure what could be blocking access to the port.
jokerv
Level 7
Report Inappropriate Content
Message 4 of 5

RE: EPO Server busy...

guys.
please verify that you running latest SQL2005 db for your ePo server - they have hardcoded app server limitation (tomcat) that use all 254 connections from clients and not able to insert data to SQL2000 db.
probably you can see many clients events on your DB\events folder now that slowly disappear...

if this a case - you need to migrate db to latest SQL

RE: EPO Server busy...

I do use SQL2005 SP2. Anyway it seems to be a rare problem and hasn't occurred again.
More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community