cancel
Showing results for 
Search instead for 
Did you mean: 
KEOLIS
Level 7
Report Inappropriate Content
Message 1 of 4

ePO upgrade 5.3 to 5.10 issue

Jump to solution

Hello,

 

I have tried to upgrade ePO from 5.3 to 5.10 but i have got this error :

[ErrorLog]
ErrorString=FAILURE: In LaunchAppAndWait while trying to run the following program:
ActionName=MerMod_RunOrionANTInstaller
"D:\Programs\McAfee\EPOLIC~1\Installer\Core\install.bat"

Return code: 1
Error Message: Incorrect function.

CustomAction: MerMod_RunOrionANTInstaller

The Pre-installation Auditor show that the database collations are different then the instance collation (  French_CI_AS vs SQL_Latin1_General_CP1_CI_AS).

The McAfee database is in AlwaysON cluster, I used the virtual host name 

Question :

Do you have any idea about the installation error ?

Do you think that the collation problem block the installation processes ?

do you think that the migration need to be one node of the cluster or there are no problems to install it on the virtual node ?

Thank you for your help 

Oussama

 

 

1 Solution

Accepted Solutions
Reliable Contributor Nielsb
Reliable Contributor
Report Inappropriate Content
Message 2 of 4

Re: ePO upgrade 5.3 to 5.10 issue

Jump to solution

Hi,

You have to disconnect/break your always-on cluster before the upgrade

Reconfigure the https://localhost:8443/core/config  into one SQL cluster node instead of your virtual clustername.

Start the ePO upgrade

and reconnect/reconfigure your always-on sql cluster after the ePO upgrade (ask your database colleague)

Reconfigure the https://localhost:8443/core/config  into your virtual clustername 

3 Replies
Reliable Contributor Nielsb
Reliable Contributor
Report Inappropriate Content
Message 2 of 4

Re: ePO upgrade 5.3 to 5.10 issue

Jump to solution

Hi,

You have to disconnect/break your always-on cluster before the upgrade

Reconfigure the https://localhost:8443/core/config  into one SQL cluster node instead of your virtual clustername.

Start the ePO upgrade

and reconnect/reconfigure your always-on sql cluster after the ePO upgrade (ask your database colleague)

Reconfigure the https://localhost:8443/core/config  into your virtual clustername 

KEOLIS
Level 7
Report Inappropriate Content
Message 3 of 4

Re: ePO upgrade 5.3 to 5.10 issue

Jump to solution
Thank you Nielsb, I found this error on core-upgrade.log and the solution is as you told me.
I'll keep you informed for this solution
Reliable Contributor Nielsb
Reliable Contributor
Report Inappropriate Content
Message 4 of 4

Re: ePO upgrade 5.3 to 5.10 issue

Jump to solution

Glad to hear and the 2nd disconnected SQL node is an extra backup:)

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community