cancel
Showing results for 
Search instead for 
Did you mean: 

ePO migration from 4.0 to 4x5/4.6 fails with "FAILURE: In LaunchAppAndWait while trying to run the following program"

We have a ePO version 4.0 still, and trying to upgrade it to either 4.6.

However, it is failing when finalizing instalation, with the error "FAILURE: In LaunchAppAndWait while trying to run the following program C:\PROGRA~1\McAfee\EPOLIC~1\jre\bin\java.exe ".

*Prior to this I have migrated SQL2000 DB to SQL2005, and this seems to be successfull and ePO is functioning.(https://community.mcafee.com/message/202910#202910)

Afrer reading the master article, below I have checked the EPO450-MSI-Install.log and verifiedthey are set to the correct value.

FAILURE: In LaunchAppAndWait while trying to run thefollowing program: C:\PROGRA~1\McAfee\EPOLIC~1\jre\bin\java.exe(Troubleshooting - Master Article)

https://kc.mcafee.com/corporate/index?page=content&id=KB60569

FAILURE: In LaunchAppAndWait, Return code: 1 (issue: 8.3naming convention is disabled)

https://kc.mcafee.com/corporate/index?page=content&id=kb51431

DONE - Registry value was set to 0

ePO 4.0 installation fails because insufficient SQLconnections are available

https://kc.mcafee.com/corporate/index?page=content&id=KB53927

DONE -  Connection wasset to 0 (= unlimited)

As ePO4.0 is already reached end of suppor life, I am kinda stuck and don't know where to go from here....

Any help would be much appriciated.

One option is to install ePO4.6 from scratch!

In this case, Would it be possible to migrate ePO 4.0 DB to 4.6?

Thanks very much

4 Replies

Re: ePO migration from 4.0 to 4x5/4.6 fails with "FAILURE: In LaunchAppAndWait while trying to run the following program"

Can you confirm that the account you use for SQL has the default database set to "master" and that the account has DBOwner permissions?

Is the database name correct (ePO4_<eposervername>)?

Are you using a SQL account or an Active Directory account to connect to the SQL DB?

If Active Directory, is the account Administrator on the SQL server and are there policies applied to the SQL server that influence the account (for example "Deny Logon Locally")?

Are there any usefull log entries in SQL?

Do you use special characters in the password for the account used to connect to SQL?

Message was edited by: mischaboender on 9/12/12 6:30:11 AM CDT
Highlighted
alexn
Level 14
Report Inappropriate Content
Message 3 of 5

Re: ePO migration from 4.0 to 4x5/4.6 fails with "FAILURE: In LaunchAppAndWait while trying to run the following program"

You must have McAfee ePolicy Orchestrator 4.0 Patch 7 (build 1363) to upgrade to 4.6 patch 3.Please verify this.

And if you want to move it to a new server,Please follow the following KB

https://kc.mcafee.com/corporate/index?page=content&id=KB51438

And Yes, it is possible to move 4.0 DB to 4.6, but before taking SQL backup, you must apply Patch 7 and then take a complete backup of SQL DB.

This will work with epo 4.6 server.

Message was edited by: alexn on 9/12/12 10:02:41 AM CDT
McAfee Employee JoeBidgood
McAfee Employee
Report Inappropriate Content
Message 4 of 5

Re: ePO migration from 4.0 to 4x5/4.6 fails with "FAILURE: In LaunchAppAndWait while trying to run the following program"

And Yes, it is possible to move 4.0 DB to 4.6, but before taking SQL backup, you must apply Patch 7 and then take a complete backup of SQL DB.

This will work with epo 4.6 server.

Message was edited by: alexn on 9/12/12 10:02:41 AM CDT

Hi... I'm afraid this is not correct: you cannot attach a 4.0 database to a 4.6 server, which is what I think the original poster was asking. The ePO database must exactly match the server that it is attached to, right down to the patch level.

HTH -

Joe

Re: ePO migration from 4.0 to 4x5/4.6 fails with "FAILURE: In LaunchAppAndWait while trying to run the following program"

first of all, thanks all for taking time to answer my question.

I was in and out of meeting yesterday, so please accept my delayed response.

another issue is that I am not a SQL man, and the inhouse SQL guy had left  ...

mischaboender

I had a look at ePO DB properties, this is (ePO4_<servername>), and permissions is blank.

We use AD account to connect to the SQL, and as far as I'm aware there are no policies set.

No special characters used

I didn't find any useful info in the logs, mainly related to backup,  but will dig in a bit more.

alex kerberos

Yes, Patch 7 is applied.

JoeBidgood

Yes, you are correct, I wanted to know whether it is possible to attache ePO4.0 P7 BD to ePO4.6.

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community