cancel
Showing results for 
Search instead for 
Did you mean: 

ePO doesn't appear to install - no tray icon

Hello,

I am working on a customers site where they are having a lot of problems deploying ePO 4. They have a freshly built server with version 4 installed that has replaced an older server running 3.5. For the vast majority of machines everything is working OK, but I've noticed when deploying the agent to some machines it either installs fine and you get a tray icon, but it doesn't appear in the ePO console, or the tray icon isn't there at all and the machine doesn't appear in the ePO console.

It's completely random, I've build several fresh machines (using a ghost images that's never had VS or ePO installed) and the agent installs fine, it registers in the console and everything is perfect. But on the flip side I've build several fresh machines where either the agent doesn't install or it does, but either way the machines don't communicate with the ePO server.

I have checked the registry and all the machines seem to have the correct settings but I don't know why this isn't working for most, but not for some.

[HKEY_LOCAL_MACHINE\SOFTWARE\Network Associates\ePolicy Orchestrator\Agent]
"Installed Path"="C:\\Program Files\\McAfee\\Common Framework"
"AgentGUID"="{65CFA0DE-E2AA-4E78-A764-8CDE94C3A5E3}"
"AgentWakeUpPort"="8081"
"ComputerName"="******"
"MacAddress"=";000FFE4C47E7;"
"IPAddress"="172.28.3.245"
"SubnetAddress"="172.28.0.0"
"SubnetMask"="255.255.0.0"
"LastASCTime"=dword:4a3b60d6
"SequenceNumber"=dword:00000005
"ePOServerList"="[*epo server name*|172.28.3.49|80"


Please help!
7 Replies

RE: ePO doesn't appear to install - no tray icon

On one of the machines where MA is installed but it's not reporting back the properties launch this: C:\Program Files\McAfee\Common Framework\cmdagent /s and at the agent screen click on send/receive properties and have a look at the log to see what it does.

RE: ePO doesn't appear to install - no tray icon

Agent Subsystem 19/06/2009 12:01:43 Info Agent is looking for events to upload
Agent Monitor 19/06/2009 12:01:43 Detail Sending Events...
Agent Subsystem 19/06/2009 12:01:33 Info Next policy enforcement in 5 minutes
Agent Subsystem 19/06/2009 12:01:33 Info Agent finished Enforcing policies
Management 19/06/2009 12:01:32 Info Enforcing Policies for McAfee Agent
Management 19/06/2009 12:01:32 Info Enforcing Policies for EPOAGENT3000
Management 19/06/2009 12:01:32 Info Enforcing Policies for EPOAGENT3000META
Agent Subsystem 19/06/2009 12:01:32 Info Agent Started Enforcing policies
Agent Monitor 19/06/2009 12:01:32 Detail Enforcing policies
Agent Subsystem 19/06/2009 12:01:15 Info Next policy enforcement in 5 minutes
Agent Subsystem 19/06/2009 12:01:15 Info Agent finished Enforcing policies
Management 19/06/2009 12:01:13 Info Enforcing Policies for McAfee Agent
Management 19/06/2009 12:01:13 Info Enforcing Policies for EPOAGENT3000
Management 19/06/2009 12:01:13 Info Enforcing Policies for EPOAGENT3000META
Management 19/06/2009 12:01:12 Info Compiling policies
Agent Subsystem 19/06/2009 12:01:12 Info Agent Started Enforcing policies
Agent Subsystem 19/06/2009 12:01:12 Info Enforcing newly downloaded policies
Agent Subsystem 19/06/2009 12:01:12 Info New server policy was successfully merged
Agent Subsystem 19/06/2009 12:01:11 Info Agent received POLICY package from ePO server
Agent Subsystem 19/06/2009 12:01:11 Info Agent communication session closed
Agent Subsystem 19/06/2009 12:01:11 Info Package uploaded to ePO Server successfully
Agent Subsystem 19/06/2009 12:01:11 Info Agent is connecting to ePO server
Agent Subsystem 19/06/2009 12:01:11 Info Agent communication session started
Management 19/06/2009 12:01:11 Info Collecting Properties
Agent Subsystem 19/06/2009 12:01:10 Info Checking Computer Name...
Agent Subsystem 19/06/2009 12:01:10 Info Checking MAC address...
Agent Subsystem 19/06/2009 12:01:10 Info Agent started performing ASCI
Agent Subsystem 19/06/2009 11:59:16 Info Next policy enforcement in 5 minutes
Agent Subsystem 19/06/2009 11:59:16 Info Agent finished Enforcing policies
Management 19/06/2009 11:59:16 Info Enforcing Policies for McAfee Agent
Management 19/06/2009 11:59:16 Info Enforcing Policies for EPOAGENT3000
Management 19/06/2009 11:59:16 Info Enforcing Policies for EPOAGENT3000META
Management 19/06/2009 11:59:16 Info Compiling policies
Agent Subsystem 19/06/2009 11:59:16 Info Agent Started Enforcing policies
Agent Monitor 19/06/2009 11:59:06 Info Agent service is running

RE: ePO doesn't appear to install - no tray icon

Have a look, using the search panel, if this computer's name appears more than once in you repo's tree (you can alsoo serach it by IP)

RE: ePO doesn't appear to install - no tray icon

Can't find the search panel, maybe the customer hasn't given me enough rights in ePO, but I looked through every group and cannot see the machine listed at all.

RE: ePO doesn't appear to install - no tray icon



I have just tried filtering the organisation by MAC address which showed no results.

RE: ePO doesn't appear to install - no tray icon

I have just manually installed VS8.7 on the machine and it updated with the ePO server perfectly. The "M" isn't appearing in the taskbar, just the shield logo. No sign of the ePO agent at all.

RE: ePO doesn't appear to install - no tray icon

try remove the value of the following registry on the client. (no need to delete the key, just clear the value)

[HKEY_LOCAL_MACHINE\SOFTWARE\Network Associates\ePolicy Orchestrator\Agent]
AgentGUID
IPAddress
MacAddress

if still not work, try reinstall the agent