cancel
Showing results for 
Search instead for 
Did you mean: 

Re: ePO Web API info

Jump to solution

the output is empty is does give any info when i try to run the command; Is there way to check whether webAPI is supported by epo 4.0 version?

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 22 of 46

Re: ePO Web API info

Jump to solution

I honestly do not believe it is - that was added in later versions of epo, but I can't tell you which one for sure.  Why are you running that version?  That has been end of life for years.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: ePO Web API info

Jump to solution

Thanks for you reply! I did got the same command from the help as well which says True and OK when i execute but no results are seen in ePO. Means it is not pushing the System to different group. 

Any suggestion on tweaking the commands? 

Sabari Kumar KB

Re: ePO Web API info

Jump to solution

Hope you all are doing well! 

I have another query similar to the original one when i try using WebAPI command to move a system from one group to another in ePO 5.9.1

Originally the command what i use to fetch the list of Groups to get their IDs is as below

curl -k -u USERNAME:PASSWORD https://HOSTNAME:PORT/remote/system.findGroups?searchText=Test

This works perfect and provides me the groups what i'm searching for along with the ID. 

Next step where i'm trying to push a machine from one group to another using the below query

curl -k -u USERNAME:PASSWORD https://HOSTNAME:PORT/remote/system.move?names=SYSTEMNAME?ids=GROUPID

This is returning "True : OK " but i don't see the system moved to the requested group. 

Could someone please advise on this? 

It would be great if some can find what is wrong in the way i'm trying to perform this action. 

Thanks in Advance, 

 

Sabari Kumar KB
Highlighted
McAfee Employee johma
McAfee Employee
Report Inappropriate Content
Message 25 of 46

Re: ePO Web API info

Jump to solution

Hi Sabari, 

You are correct, however there seems to be a problem with interpretation in the browser and or the way that curl interprets the command that is passed. 

Try this:
curl -k -u USERNAME:PASSWORD "https://HOSTNAME:PORT/remote/system.move?names=SYSTEMNAME&"parentGroupId"=GROUPID"


please replace all CAPS for the relevant details from your environment and use the quotation marks where specified. Should work for you. 





Was my reply helpful?


If this information was helpful in any way, or answered your question, will you please select "Accept as Solution" in my reply, or give kudos as appropriate, so together we can help other members?

Re: ePO Web API info

Jump to solution
This worked perfect! So the issue was with the place where quotation marks was inserted. Thanks a Lot!
Sabari Kumar KB

Re: ePO Web API info

Jump to solution

Hello All,

I used the Web-API curl to capture the data from ePO for the managed systems in CVS/Json format; however i am getting data, but the IP address is not getting captured correctly. 

When I select IP address in the query, i am getting the IPv6 information as a output, however i am looking for IPv4, when i select IPv4 (deprecated) in the query i am getting output as show below;

IPv4 Address (deprecated): -1969304615


Could someone please assist me how to fix this issue and get the correct format of the IPv4?

Regards,

Mahesh

 

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 28 of 46

Re: ePO Web API info

Jump to solution
When you are in the epo console and go into that system properties, does the ipv4 address show there, or just ipv6?

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: ePO Web API info

Jump to solution

In the ePO we see only IPv4 and also when i try to run the query from the ePO it shows the IPv4 only. But we pull it VIA webAPI it shows below 

IP Address: 0:0:0:0:0:FFFF:A9E
Address (deprecated): -1969300011

Regards,

Mahesh

 

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 30 of 46

Re: ePO Web API info

Jump to solution
What exact web api command are you running? You can put a generic servername, credentials to remove any private info.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community