cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
hippy
Level 7
Report Inappropriate Content
Message 1 of 3

ePO Product Deployment question

Jump to solution

I have a deployment task in ePO4.5 to deliver MA 4.5 4.5.0.1810 to a small number of machines. This will be an upgrade from the existing MA 4.5.0.1270. Originally I had the schedule to run once per day at 9.00PM and I left it overnight and the two test systems I targetted one upgraded the other did not. Also the option to run at every policy enforcement intervall is selected. To further test after the failur I sent the task to run every 30 mins. Still no joy.

On the machine that did not upgrade n the morning I did an agent wake up call with full product properties selected. This still did not upgade the MA. Only by going onto the failing machine and going to the Agent Status Monitor and clicking Collect and send properties, Send events, Check for new Policies, Enforce Policies did the MA actually upgrade.

Any ideas my this might be happening?

1 Solution

Accepted Solutions

Re: ePO Product Deployment question

Jump to solution

Can you try install MA 4.5.0.1810 via command /forceinstall?

On the local client:

cmd > generated package from ePO with command = framepkg.exe /forceinstall

Via remote install:

1) download psexec tool - http://technet.microsoft.com/en-us/sysinternals/bb897553

2) copy package framepgk.exe on the local client to the folder c:/temp/

3) run cmd and browser folder where is downloaded psexec.exe and use this command >

psexec \\name_pc "C:\Temp\framepkg.exe" /Install=AGENT /FORCEINSTALL /SILENT

If new MA still not installed, you have to open registry on the client computer and remove this tree > [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\ADE3EF6381C0ED8439B49D68 F2287A8A] - ADE... is McAfee Agent, it is possible, that you have another description.

Good luck.

Michal

Message was edited by: michall on 02/06/11 13:00:20 CEST
2 Replies

Re: ePO Product Deployment question

Jump to solution

Can you try install MA 4.5.0.1810 via command /forceinstall?

On the local client:

cmd > generated package from ePO with command = framepkg.exe /forceinstall

Via remote install:

1) download psexec tool - http://technet.microsoft.com/en-us/sysinternals/bb897553

2) copy package framepgk.exe on the local client to the folder c:/temp/

3) run cmd and browser folder where is downloaded psexec.exe and use this command >

psexec \\name_pc "C:\Temp\framepkg.exe" /Install=AGENT /FORCEINSTALL /SILENT

If new MA still not installed, you have to open registry on the client computer and remove this tree > [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\ADE3EF6381C0ED8439B49D68 F2287A8A] - ADE... is McAfee Agent, it is possible, that you have another description.

Good luck.

Michal

Message was edited by: michall on 02/06/11 13:00:20 CEST
apoling
Level 14
Report Inappropriate Content
Message 3 of 3

Re: ePO Product Deployment question

Jump to solution

Hello,

The FRMINST_hostname.LOG and the MFEagent.msi.x.x.xxx.log might tell you more about the failure. Look for the timestamp of the failing installation.

(You might find this file on that computer at %TEMP%\McAfeeLogs folder.)

Attila

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community