cancel
Showing results for 
Search instead for 
Did you mean: 

ePO Agents not updating DAT or Engine

I'm trying to upgrade a remote site from VSE800 to VSE850, whilst switching from an ePO 3.6 to an ePO 4.0 server. I've pushed the Agent from the new server to some test clients and they've all downloaded and installed VSE850 and are checking for updates against the new server okay, but won't download any patches, DAT's or Engine updates.

The regular Agent update task reports the following:

01 July 2008 09:50:24 Info Agent Agent Started Enforcing policies
01 July 2008 09:50:24 Info Management Enforcing Policies for SNOWCAP_2000
01 July 2008 09:50:24 Info Management Enforcing Policies for PATCH___1100
01 July 2008 09:50:24 Info Management Enforcing Policies for EPOAGENT3000META
01 July 2008 09:50:24 Info Management Enforcing Policies for EPOAGENT3000
01 July 2008 09:50:24 Info Management Enforcing Policies for McAfee Agent
01 July 2008 09:50:25 Info Scheduler Added a new task Software Deployment to Scheduler's task list
01 July 2008 09:50:25 Info Agent Agent finished Enforcing policies
01 July 2008 09:50:25 Info Agent Next policy enforcement in 30 minutes
01 July 2008 09:50:26 Info Scheduler Scheduler: Invoking task [Software Deployment]...
01 July 2008 09:50:27 Info Updater Checking update packages from repository ePOSA_LEGUAAN.
01 July 2008 09:50:28 Info Updater Initializing update...
01 July 2008 09:50:28 Info Updater Verifying catalog.z.
01 July 2008 09:50:28 Info Updater Extracting catalog.z.
01 July 2008 09:50:28 Info Updater Loading update configuration from: catalog.xml
01 July 2008 09:50:29 Info Updater Checking for software conflicts.
01 July 2008 09:50:29 Info Updater Verifying VSE850Det.mcs.
01 July 2008 09:50:29 Info Updater Verifying VSE850Det.mcs.
01 July 2008 09:50:29 Info Updater Verifying PatchDet.McS.
01 July 2008 09:50:29 Info Updater Verifying PatchDet.McS.
01 July 2008 09:50:30 Info Updater Verifying MAS850det.mcs.
01 July 2008 09:50:30 Info Updater Verifying MAS850det.mcs.
01 July 2008 09:50:30 Info Updater Update Finished
01 July 2008 09:50:30 Info Scheduler The task Software Deployment is successful
01 July 2008 09:50:30 Info Scheduler Scheduler: Task [Software Deployment] is finished


Manually updating from the AV client, produces the following log, note the errors "Error occurred while loading required component" when trying to update the engine and the DAT:

01 July 2008 10:01:35 Info Updater Checking update packages from repository ePOSA_LEGUAAN.
01 July 2008 10:01:36 Info Updater Initializing update...
01 July 2008 10:01:36 Info Updater Verifying catalog.z.
01 July 2008 10:01:36 Info Updater Extracting catalog.z.
01 July 2008 10:01:36 Info Updater Loading update configuration from: catalog.xml
01 July 2008 10:01:37 Info Updater These updates will be applied if they are in the repository: Engine, DAT, EPOAGENT3000META, VIRUSCAN8600, PATCHTMP1000, PATCHTMP2000, SPAMSAFE1000.
01 July 2008 10:01:37 Info Updater Downloading PkgCatalog.z.
01 July 2008 10:01:37 Info Updater Verifying PkgCatalog.z.
01 July 2008 10:01:37 Info Updater Extracting PkgCatalog.z.
01 July 2008 10:01:37 Info Updater Loading update configuration from: PkgCatalog.xml
01 July 2008 10:01:38 Info Updater Verifying V2EngDet.mcs.
01 July 2008 10:01:38 Info Updater Searching available updates for Engine.
01 July 2008 10:01:38 Info Updater Error occurred while loading required component.
01 July 2008 10:01:38 Info Updater Downloading PkgCatalog.z.
01 July 2008 10:01:38 Info Updater Verifying PkgCatalog.z.
01 July 2008 10:01:38 Info Updater Extracting PkgCatalog.z.
01 July 2008 10:01:38 Info Updater Loading update configuration from: PkgCatalog.xml
01 July 2008 10:01:39 Info Updater Verifying V2datdet.mcs.
01 July 2008 10:01:40 Info Updater Error occurred while loading required component.
01 July 2008 10:01:40 Info Updater Verifying AgtMetaDet.McS.
01 July 2008 10:01:40 Info Updater Searching available updates for McAfee Agent Plugin.
01 July 2008 10:01:40 Info Updater Product(s) running the latest Plugin.
01 July 2008 10:01:40 Info Updater Verifying VSE850Det.mcs.
01 July 2008 10:01:40 Info Updater Searching available updates for McAfee VirusScan Enterprise 8.5.0.
01 July 2008 10:01:40 Info Updater Product(s) running the latest HotFix 5.
01 July 2008 10:01:40 Info Updater Verifying PatchTmpDet.McS.
01 July 2008 10:01:40 Info Updater Searching available updates for System Compliance Profiler Templates.
01 July 2008 10:01:40 Info Updater Downloading PkgCatalog.z.
01 July 2008 10:01:40 Info Updater Verifying PkgCatalog.z.
01 July 2008 10:01:40 Info Updater Extracting PkgCatalog.z.
01 July 2008 10:01:40 Info Updater Loading update configuration from: PkgCatalog.xml
01 July 2008 10:01:42 Info Updater Starting System Compliance Profiler Templates update.
01 July 2008 10:01:42 Info Updater Downloading System Compliance Profiler Templates.
01 July 2008 10:01:42 Info Updater Downloading Ptchscan.scp.zip.
01 July 2008 10:01:42 Info Updater Copying PtchScan.scp.
01 July 2008 10:01:42 Info Updater Verifying PatchTmpDet.McS.
01 July 2008 10:01:43 Info Updater Searching available updates for System Compliance Profiler Templates.
01 July 2008 10:01:43 Info Updater Downloading PkgCatalog.z.
01 July 2008 10:01:43 Info Updater Verifying PkgCatalog.z.
01 July 2008 10:01:43 Info Updater Extracting PkgCatalog.z.
01 July 2008 10:01:43 Info Updater Loading update configuration from: PkgCatalog.xml
01 July 2008 10:01:44 Info Updater Starting System Compliance Profiler Templates update.
01 July 2008 10:01:44 Info Updater Downloading System Compliance Profiler Templates.
01 July 2008 10:01:44 Info Updater Downloading Ptchscan.scp.zip.
01 July 2008 10:01:45 Info Updater Copying PtchScan.scp.
01 July 2008 10:01:45 Info Updater Verifying SK_det.mcs.
01 July 2008 10:01:45 Info Updater Downloading SK_det.mcs.
01 July 2008 10:01:47 Info Updater Update Finished


This problem is happening on all test clients at the remote site. The remote site has two repositories, which have replicated all packages from the main server. The clients are all reporting back to the ePO server regularly and ePO is showing they're running Agent v4, but VSE850 isn't listed on any of the clients.
18 Replies
tonyb99
Level 13
Report Inappropriate Content
Message 2 of 19

RE: ePO Agents not updating DAT or Engine

checking in repos on epo 4 server you do have 5200 engine checked in?

RE: ePO Agents not updating DAT or Engine

Yes, all packages are checked into the repos
tonyb99
Level 13
Report Inappropriate Content
Message 4 of 19

RE: ePO Agents not updating DAT or Engine

Have you tried rechecking in the 5200 engine

RE: ePO Agents not updating DAT or Engine



Just re-checked in the engine and replicated to the repos. A manual update reports the same errors.

RE: ePO Agents not updating DAT or Engine

I've found the problem. VSE800 is not cleanly removing before VSE850 is installed.

To workaround this, I've got to clean every PC of McAfee before deploying the 4.0 Agent.

To fix the machines I've already pushed the 4.0 Agent to, I've had to manually rollback the VSE850 install via "framepkg /forceinstall /install=agent"
David.G
Level 7
Report Inappropriate Content
Message 7 of 19

RE: ePO Agents not updating DAT or Engine

I'm having that same issue as I'm migrating clients from ePO3.6/VS8.0 to a new ePO 4.0 server and VS8.5.
The VS 8.5 seems to install ok, but the DAT and engine files are "locked" to those versions that come with the deployment package. (Engine:5200.2160, DAT:5309.0000)

This occurs on "only" about 10% of the machines. I have yet to figure out a pattern.

Can anyone suggest an easy fix that would not require visiting the remote machines?

In my repository I host: Engine 5300.2777 and the latest DAT (5424).

On a target machine UpdateLog I get:

Starting task: AutoUpdate
Checking update packages from repository ePO_MasterRep.
Initializing update...
Verifying catalog.z.
Extracting catalog.z.
Loading update configuration from: catalog.xml
These updates will be applied if they are in the repository: Engine, DAT, EPOAGENT3000META, VIRUSCAN8600, PATCHTMP1000, PATCHTMP2000, ENCPTCNT6000, SPAMSAFE1000.
Downloading PkgCatalog.z.
Verifying PkgCatalog.z.
Extracting PkgCatalog.z.
Loading update configuration from: PkgCatalog.xml
Verifying V2engdet.mcs.
Error occurred while loading required component.

Thanks for any suggestions.
Dave.

RE: ePO Agents not updating DAT or Engine



I have this issue on 2 machines and its driving me crazy.
Im not sure what Jon is doing in the quote above. What exactly does
"framepkg /forceinstall /install=agent" do to resolve this? :confused:
Highlighted

RE: ePO Agents not updating DAT or Engine

Any ideas here? Ive tried everything I can think of short of reinstalling windows to get the McAfee products to work. The 2 systems seem to be stuck at DAT version 5381.0000

Im running the latest EPO 4 & Agent plus the latest VSE8.7i
VSE8.7i works fine but no dats will update.
c-r-h
Level 7
Report Inappropriate Content
Message 10 of 19

RE: ePO Agents not updating DAT or Engine



I had a few machines which would not update the Dat file when I upgraded to EPO 4, Agent 4.0.0.1345 and VSE 8.7.

I got them to update to the correct version by doing the following:

1)
First stop the "Access Protection" from McAfee VirusScan Console. This can either be done via connecting using the "Open Remote Session" on another console and entering the client name or locally on the machine.

2)
Then stop the "McAfee McShield" and "McAfee Engine Service" services running from Windows's Computer Management. Again this can be done remotely or locally.

3)
Next delete the "Engine" directory on the client machine in "C:\Program Files\Common Files\McAfee".

4)
Now copy the "Engine" directory from another client that is running the correct Dat file.

5)
Once the "Engine" directory has copied restart the"McAfee Engine Service" and "McAfee McShield" services. ( This can take a while ).

6)
Then restart the "Access Protection" from VirusScan Console.

7)
Now if you redeploy the agent to the client from the EPO Server, it should register it as having the correct Dat file.

Hope this helps.
More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community