cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
jround
Level 9
Report Inappropriate Content
Message 1 of 3

ePO 5.9 Pre-Installation Auditor 2.2.0.129 Extension Check Issue

After recently upgrading our ePO from 5.3.2 to 5.3.3 plus the various hot fixes, I thought I would take a look at what issues we need to resolve before making the bigger jump to ePO 5.9.1.

So I downloaded the PIA 2.2.0.129 tool and ran it on the ePO server, I put in the SQL sa credentials and also an AD administrator account which all passes and runs the initial checks fine, some issues to resolve but that is to be expected.

On the next screen I enter a McAfee ePO Admin User Name and McAfee ePO Admin Password (tried both a local one and AD authenticated one, both with the full Administrator rights selected in ePO) and run the 'Product Compatibility Check'.  After a minute or so an error appears at the bottom stating 'Unable to load the list of installed products.  Check your McAfee ePO credentials and try again.'

The cpcwiz reports the following :-

31/05/2018 10:36:56 Server URL: https://mcafeeepo:8443
31/05/2018 10:36:56 Server object: /remote/ext.list.do
31/05/2018 10:36:56 Server login: myloginname
31/05/2018 10:36:56 Failed WinHttpSendRequest() Error: 12175
31/05/2018 10:36:56 Failed both attempts at loading product list

The strange thing is, if I manually browse to https://mcafeeepo:8443/remote/ext.list.do it prompts for a login so I login using the same ePO credentials and up pops the file containing a list of installed extensions etc!  So no idea why the checker is failing to connect/read from it?!

2 Replies
McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 2 of 3

Re: ePO 5.9 Pre-Installation Auditor 2.2.0.129 Extension Check Issue

There is a defect on this issue - it will be resolved in version 3.0.  In the install files for epo 5.9.1, under upgrade compatibility, run the upgradecompatibility.exe to see if you have the same issue.  You can use that as a workaround.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: ePO 5.9 Pre-Installation Auditor 2.2.0.129 Extension Check Issue

We had a similar issue. Are you using the most current PIA? There's also a PIA bundled with the ePO 5.9.1 software. We only had one of the two that worked for us.

MPower Badge Now Available
Customers attending MPower can earn a community badge. Check into the MPower forum and say hi to have the badge awarded to your community profile.