cancel
Showing results for 
Search instead for 
Did you mean: 
alby99
Level 7
Report Inappropriate Content
Message 1 of 14

ePO 5.1 system tree sorting doesn't work automatically

I have a couple of ePO 5.1.1 servers both of which display the same characteristics in that system tree sorting does not happen automatically, which I was of the understanding should happen.

In Server Settings the System Tree Sorting option is set to Sort systems on each agent-server communication.

I have created Tags for my various server and workstation types which are evaluated on each agent-server communication.

I have created a system tree with subtrees and subgroups into which the Tags should be sorted. In each of the sub groups I have set a Sorting criteria based on the various tags.

No automated sorting ever takes place although if I initiate a manual sort from the System Tree (Actions / Directory Management / Sort Now or Test Sort) the tree is correctly sorted. Have I missed something, or is my understanding of what is supposed to happen just wrong? Do I need to create a server task to automate the sorting?

Thanks,

Simon

13 Replies
andrep1
Level 14
Report Inappropriate Content
Message 2 of 14

Re: ePO 5.1 system tree sorting doesn't work automatically

Have a look at these options in the server settings:

  
  
  

With the manual sort, it would always work

HTH

alby99
Level 7
Report Inappropriate Content
Message 3 of 14

Re: ePO 5.1 system tree sorting doesn't work automatically

Unfortunately, per my original posting, the servers settings are set to Sort systems on each agent-server communication. See below.

System Tree sorting: 

      
      
    
aus_mick
Level 10
Report Inappropriate Content
Message 4 of 14

Re: ePO 5.1 system tree sorting doesn't work automatically

Have you confirmed that System Tree Sorting is enabled for your systems?

alby99
Level 7
Report Inappropriate Content
Message 5 of 14

Re: ePO 5.1 system tree sorting doesn't work automatically

Per my previous post, System Tree sorting is set to Sort systems on each agent-server communication, in addition Tags are evaluated on each agent-server communication. The Tag evaluation works fine but not the system tree sorting.

Is there somewhere else I need to look?

Thanks

alby99
Level 7
Report Inappropriate Content
Message 6 of 14

Re: ePO 5.1 system tree sorting doesn't work automatically

I've just done a quick check of what I originally wrote only to find that doing a manual sort using the Actions / Directory Management / Sort Now option does not in fact work. Doing a Test Sort does work ie it correctly identifies where the selected machines should be placed in the System Tree, and if you subsequently choose to move them, they do in fact end up where they should be. So perhaps the Sort algorithm is working but the Move part of it (in Sort Now) isn't.

andrep1
Level 14
Report Inappropriate Content
Message 7 of 14

Re: ePO 5.1 system tree sorting doesn't work automatically

So is everything is in lost and found ?

alby99
Level 7
Report Inappropriate Content
Message 8 of 14

Re: ePO 5.1 system tree sorting doesn't work automatically

You might think that everything would end up in Lost&Found but no, that has not happened. There are 2 machines only in Lost&Found, both show as managed and have valid Tags, although neither has communicated within the last 17 days. I have tried sorting a subset of machines which are in My Organisation\MyDomain and they should be moved, based on their tags, to a mix of subgroups below MyDomain but they stubbornly refuse to move. I have tried sorting both managed and unmanaged machines, but none of them is moved anywhere. A Test Sort shows that all of the unmanaged machines should be moved to Lost&Found and that all managed machines should be moved to their respective sub groups, it just doesn't happen when Sort Now is chosen.

aus_mick
Level 10
Report Inappropriate Content
Message 9 of 14

Re: ePO 5.1 system tree sorting doesn't work automatically

Have you checked each system doesn't have Sorting disabled? Easiest way to is add the System Tree Sorting property to your System Tree view. You can enable your tagging criteria to evaluate on each agent-server communication and have a global System Tree Sorting setting to sort on each agent-server communication, however if sorting of the system is disabled it wont be sorted, even if you attempt to manually.

System_Tree_Sorting_Status.jpg

If sorting is disabled you can change the status by select the target systems and from Actions | Directory | Change Sorting Status).

Change_Sorting.jpg

HTH, Mick

alby99
Level 7
Report Inappropriate Content
Message 10 of 14

Re: ePO 5.1 system tree sorting doesn't work automatically

Mick,

Thanks, you've nailed the problem on the head. I had no idea that you needed to enable system tree sorting per device. Kinda defeats the purpose I would have thought. Surely there is a way to have your devices automatically sorted into the appropriate sub-group without first having to enable System Tree Sorting on each device? I'm sure I can create a server task to do that, and in fact already do for some devices for which there are insufficient tagging options.

Regards,

Simon