Showing results for 
Search instead for 
Did you mean: 

ePO 4.6 on Mac OSX


Would anyone be able to offer any advice on the above. We have tried to push the McAfee agent for Mac OSX 4.6 to Macs running 10.7. The server log indicated that the task had started but after 15 minutes or so, reports back that the task failed. We pushed it with AD domain admin credentials at the Macs FQDN. SSH is enabled on the Macs we have been trying, there is no firewall and the machine responds to a ping.

Any advice or comments would be gratefully recieved.

Many thanks

Ed Stout

3 Replies

Re: ePO 4.6 on Mac OSX

Having some similar issues.  At times this has worked fine, other times not.  I did find some DNS issues for us - DHCP is non-windows, and doesn't update MS DNS...Also found that ePO uses netbios names...might be some details in the subtask that will help.

Re: ePO 4.6 on Mac OSX

Having similar issues.  My mac shows up in the ePO but iPO won't push anything to the mac.  I'll see if netbios names is an issue here.  Any help will be appreciated.  I've been watching this post since it went up.  ~Thanks

Re: ePO 4.6 on Mac OSX

Right now I'm able to push with ePO to the Macs over SSH using the root cred...if you have a consistent root cred.  As for using AD, how are you binding AD to  the Macs?  Many of my DNS problems are going away since making some changes to DNS settings with our AD integration software.  Cisco DHCP doesn't update Microsoft DNS, so it's up to the client to update DNS.  Thought about using a hosts file in the ePO server, but that's a lot to maintain.

Our site had issues losing the Macs communication to ePO post ePO 4.5-4.6 upgrade.  In attempts to regain control I learned that upgrading McAfee Agent from 4.5 to 4.6 rarely works - the upgrade iteself succeeds, but usually won't check in even when sent wake ups and command line options to collect/update/enforce locally from the agent 'managed' mac...But, if I then use Apple Remote Desktop to remove the agent with the 'unix' command /Library/McAfee/cma/ (run as root). and then re-push the MA 4.6, it checks in just fine even without a reboot.