cancel
Showing results for 
Search instead for 
Did you mean: 

ePO 4.6.1 Web Interface Down

Hi,

After installing Windows Updates for a customer server and then rebooting it, the ePO console (https://localhost:8443/core/orionSplashScreen.do) now gives us a HTTP 500 error. Accessing the config page (https://localhost:8443/core/config) works fine, and the "Test Connection" button returns successfully.

All ePO services are running.

The orion.log file contains the following latest entry:

2014-09-22 09:25:20,272 ERROR [http-8443-Processor19] servlet.ControllerServlet  - an unexpected error occurred while core's bean factory was not available

org.springframework.beans.factory.BeanCreationException: Bean factory is shut down

  at com.mcafee.orion.core.spring.MultiParentBeanFactory.checkEnabled(MultiParentBeanFactory.java:382)

  at com.mcafee.orion.core.spring.MultiParentBeanFactory.getBean(MultiParentBeanFactory.java:180)

  at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:160)

  at com.mcafee.orion.core.servlet.LoginServlet.addLoginHook(LoginServlet.java:238)

  at com.mcafee.orion.core.servlet.LoginServlet.doPost(LoginServlet.java:231)

  at com.mcafee.orion.core.servlet.LoginServlet.doGet(LoginServlet.java:60)

  at javax.servlet.http.HttpServlet.service(HttpServlet.java:627)

  at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)

  at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)

  at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)

  at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:659)

  at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:457)

  at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:395)

  at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:311)

  at org.apache.catalina.authenticator.FormAuthenticator.forwardToLoginPage(FormAuthenticator.java:321)

  at org.apache.catalina.authenticator.FormAuthenticator.authenticate(FormAuthenticator.java:245)

  at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:528)

  at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)

  at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)

  at com.mcafee.orion.core.server.AjaxValve.invoke(AjaxValve.java:84)

  at com.mcafee.orion.core.server.OrionUserSetupValve.invoke(OrionUserSetupValve.java:41)

  at org.apache.catalina.authenticator.SingleSignOn.invoke(SingleSignOn.java:393)

  at com.mcafee.orion.core.server.OrionSingleSignOn.invoke(OrionSingleSignOn.java:141)

  at com.mcafee.orion.core.server.ClientCertValve.invoke(ClientCertValve.java:69)

  at com.mcafee.orion.core.server.ParameterEncodingValve.invoke(ParameterEncodingValve.java:37)

  at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)

  at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:174)

  at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:879)

  at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665)

  at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528)

  at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81)

  at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)

  at java.lang.Thread.run(Thread.java:619)

2 Replies

Re: ePO 4.6.1 Web Interface Down

HTTP 500 is obviously something internal to your server, seeing that your ePO config page loads fine and your DB connection is fine, its something within Apache. Have you tried restarting the McAfee services again or rebooting it again?

Did you install any new extensions in ePO or anything?

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 3 of 3

Re: ePO 4.6.1 Web Interface Down

(Just as an aside, it's unlikely to be Apache - the ePO web interface is provided entirely by the application server service, which is tomcat.)

A more likely cause would be an extension problem, which is most easily seen in the orion log when ePO is starting up. To the OP - please restart the application server service (which will prompt you to restart the server service as well) - when the console is available again, please zip up and attach the orion logs from ..\server\logs. (The files I mean are orion.log, orion.log.1 and so on.)

Thanks -

Joe