cancel
Showing results for 
Search instead for 
Did you mean: 
philou
Level 7
Report Inappropriate Content
Message 1 of 4

ePO 4.0 uninstalled but can't reinstall

Hello,

I'm having a lot of trouble to install ePO 4.0 (and patch 2).
After i got somehow manged to installed ePO 4.0 + Patch 2, i finally removed it to make a clean install.

Uninstall went OK, it removed ePO 4.0 , i also removed everything related to SQL Server 2005.

I though i had a clean system again to begin with, but when i run ePO 4.0 installer again, it says it detects an already installed ePO 4.0.

The dialog screen says "Remove McAfee ePolicy Orchestrator , This will remove ePolicy Orchestrator from your computer"
There's also a check box to uninstall the database but as i said, it's already gone.

My only option here is "Remove" , which i click, followed by 2 other dialogs to confirm i really want to uninstall ePO 4.0.

Then program quits, and here is what i have in the NAILogs/EPO400-Install-MSI.LOG log file:

...
1: Setting the current directory to [C:\epo400l].
1: End getListOfDomainsAndSQLServers
1: End InitializeInstallation
1: Calculating the JAVA Language settings based on the System Language detected as [English(1033)]
1: JAVA Language set to the following: [-Duser.language=en -Duser.country=US]
MSI (c) (C0:60) [10:48:21:140]: PROPERTY CHANGE: Adding JAVALANGINFO property. Its value is '-Duser.language=en -Duser.country=US'.
1: Setup detected that ePO is already installed so check if this is a license upgrade.
1: setNaiLicense: [C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\{E9B09C6A-3700-43B6-92AF-9208B9C069C8}\SetLicense.Exe] [/getlicensetype] [C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\{E9B09C6A-3700-43B6-92AF-9208B9C069C8}\]
1: setNaiLicense return Code = [400]
1: Wrong installed license type (Licensed) detected so skipping license upgrade.
1: Valid upgrade not detected so running Add/Remove UI.
1: Start checkSystemForProblems
1: Loading the following DLL for Use: [C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\{E9B09C6A-3700-43B6-92AF-9208B9C069C8}\CommonSetup.DLL]
1: Setting the current directory to [C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\{E9B09C6A-3700-43B6-92AF-9208B9C069C8}].
1: Unloading the following DLL: [C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\{E9B09C6A-3700-43B6-92AF-9208B9C069C8}\CommonSetup.DLL]
1: Setting the current directory to [C:\epo400l].
1: End checkSystemForProblems
1: User selected to remove ePO from the system.
1: User selected to leave the ePO database behind so skip removal.
1: User selected YES so performing the uninstall.
1: User selected YES to skip backing up of the keys so performing the uninstall.
InstallShield 10:50:31: Failed to create uninstallation information, error is 0x80004005
=== Verbose logging stopped: 10/16/2008 10:50:31 ===

Googled on error 0x80004005 => nothing interesting.


How does it detect that ePO is already installed, when everything has been uninstalled ?

How can i uninstall _everything_ ePO 4.0 related (registry keys, installshield files,etc..) ?

Any help welcome Smiley Happy

Thanks,

Philou
3 Replies

RE: ePO 4.0 uninstalled but can't reinstall

there are no official instructions

is epo 4.0 still visible in add/remove programs?
philou
Level 7
Report Inappropriate Content
Message 3 of 4

RE: ePO 4.0 uninstalled but can't reinstall

Hello,

Well, as the uninstallation of ePo 4.0 went smoothly through Add/Remove Programms, there is nothing left in Add/Remove Programs, related to ePo 4.0 nor SQL Server 2005.

McAfee provides a tool called MCPR (McAfee Consumer Product Removal) for desktop products, that can completely uninstall a product.

Is there such a program that can completely uninstall ePo 4.0 (registry keys,etc..) ?

I wouldn't think that i need to reinstall the server and all other installed software, just because i can't run the installer again Smiley Sad

There _must_ be a way to tell the installer that the computer has no "installed" ePo 4.0 on it.

Thanks for your help,

Philou

RE: ePO 4.0 uninstalled but can't reinstall

I would ensure that you have rebooted the machine after uninstall to ensure that all DLLs have been unloaded. I would then check the registry for any registry that notes EPO.