cancel
Showing results for 
Search instead for 
Did you mean: 
U4iA
Level 7
Report Inappropriate Content
Message 1 of 17

ePO 4.0: Unable to update clients

I have installed ePO 4.0 on a 2003 Server and checked in the packages for VirusScan 8.5i, VSE8.5i Patch 3 and SiteAdvisor Enterprise 1.5. The agent and VSE8.5i (without updates and Patch 3) was installed on all machines. The only machine which appear to be up-to-date is the ePO Server itself, all other machines are not succesfull in retrieving the updates.

I tried to manually install the latest SDAT on the servers (not the workstation), because we need it protected asap. When we try this it shows the following message: Error: Product rejected the update request. The Scan Engine stays 5100.0194 and the Virus DAT version 4893. There's not much to be found in the log files.

Also it seems SiteAdvisor isn't installed, which is strange because it's scheduled in the same task as the deployment of VSE8.5i. Maybe I'm overlooking something?
16 Replies
Frever
Level 7
Report Inappropriate Content
Message 2 of 17

RE: ePO 4.0: Unable to update clients

I want to apologise in advance if i'm stating the obvious.
But you did create a pull task, right ?
A task that periodically pulls the updates from the McAfee HTTP or FTP source repository ?
twenden
Level 13
Report Inappropriate Content
Message 3 of 17

RE: ePO 4.0: Unable to update clients

I have done very limited testing with EPO 4.0i. When I installed it on my test server, I also ran into a problem with my 5 test clients not being able to contact the server.

This was caused by the Windows 2003 firewall. With EPO 3.6.1 the location of the apache.exe was in a different location. This caused the clients to be unable to communicate with the server.

I had to modify the 2003 server firewall settings for the new path which is

C:\program files\mcafee\epolicy orchestrator\apache2\bin\apache.exe

Making this change made all my test clients start updating from the EPO 4.0 test server.

Not too sure if this is the problem that you are having.

Clients not updating

I'm having the same issue on a 2000 server machine.

I did create a pull task...but the desktops are not updating.

The desktops were installed when we had Protection Pilot - they are up to date.

Thanks!
tonyb99
Level 13
Report Inappropriate Content
Message 5 of 17

RE: Clients not updating

do you have dual nics with multiple ip adresses on the server? if so have you set the server IP in the server.ini
U4iA
Level 7
Report Inappropriate Content
Message 6 of 17

RE: Clients not updating

To give you an update:
I called Gold Support and the examined the logfiles over and over. It now seems I'm not the only one with this problem and occurs more with ePO 4.0 and VSE8.5 with Patch 3. According to the information now this problem should be resolved in Patch 4 for VSE8.5. The only problem is that you cannot uninstall them from the Add/Remove menu. The only way to remove the faulty scanner is bij starting a manual installation from the setup.exe and click Remove. Unless you allready have Patch 4, the only way is to manually install it. If I have any further information, I will post it here...
tonyb99
Level 13
Report Inappropriate Content
Message 7 of 17

RE: Clients not updating

You can script the removal of patch 3 from an VSE install using the uninstall script in the patch 3 readme file (see extract below).

REMOVING THE PATCH
Windows Installer 3.x and later now support the
rolling back of Patches. This can be done one of
two ways.
- For Windows XP, Windows 2003, and Windows Vista
operating systems, the Patch can be removed
manually via Add/Remove Programs if the user has
administrative rights to the local system.
- For all operating systems that support Windows
Installer 3.x, a command-line option can be used
to remove the Patch silently.
Example:
Msiexec.exe /I {35C03C04-3F1F-42C2-A989-A757EE691F65}
MSIPATCHREMOVE={35F6D0CC-1A68-438B-ACC4-8808BD85C594} /q
NOTES:
- The GUID information used here will change
from one Patch to another, so please use the
information in the Release Notes for the
patch that you are removing.
- Because the patch is removed via MSIEXEC the
functions inside setup.exe, that normally
prevent reboots from occurring during silent
processes, do not get executed. In order to
prevent a possible automatic reboot from
occurring after patch removal, simply add the
REBOOT=R parameter to the command-line option
above.
- Patch removal is an MSI reinstall function.
When a patch is removed, all features
affected by the patch will get reset to
installation defaults. Any features not
modified by the patch will be left with their
current settings.
U4iA
Level 7
Report Inappropriate Content
Message 8 of 17

RE: Clients not updating

Patch 3 is not the problem. Even without a patch or Patch 1 the problem occurs. Guess I'll have to wait for Patch 4 to be sure this resolves this issue. Thanks (all of you) for you help though happy

RE: Clients not updating

I'm getting the same problem. Have you found a solution yet? the Version 4 patch doesn't do anything to fix this either.
tonyb99
Level 13
Report Inappropriate Content
Message 10 of 17

RE: Clients not updating

Moving this thread to the EPO board...


have you checked your tasks as (see thread on EPO boards) Mcafee advise that the 3.6.0.546 and 3.6.0.569 agents DONT support logon tasks, so if your DAT update is set as a logon task you need to re schedule it for specific times.