cancel
Showing results for 
Search instead for 
Did you mean: 
harris_s
Level 9

Windows 10 build 1703 and Agent 5.0.5 installation fails

Hi,

Our Windows 10 machines have updated to the latest creator update, unfortunately as a result all of our agents have stopped communicating with the epo server. I was using agent 4.8.0.1938. At the moment the computers have no mcafee products on them and I'm unable to deply any agent to them (tried the latest 5.0.5). If I manually install the agent it does go on the computer but will still not communicate with the epo server. Am I missing something here, the technotes say that the agent and virusscan are compatible but they won't install. I had a similar issue when anniversary update came out.

Anyone any ideas, having to use defender at the moment!

Thanks in advance.

16 Replies
syedali
Level 11

Re: Windows 10 build 1703 and Agent 5.0.5 installation fails

Hello Harris,

Please refer the below recommended upgrade path for McAfee agent 5.0.5 and VSE.

McAfee Corporate KB - Recommended upgrade paths for McAfee Agent, Host Intrusion Prevention, and Vir...

Thanks,

Syed

0 Kudos
johnmoe
Level 11

Re: Windows 10 build 1703 and Agent 5.0.5 installation fails

Which agent package did you use to install?  The one downloaded from McAfee, or one generated from your ePO server.  If it's the one from McAfee, it won't have your server information, so it won't connect to anything.  You'll need to generate a package from your ePO server and use that.  Otherwise, when you push the install, what comes up in the install log?  It can be found under %temp%\McAfeeLogs, where %temp% is usually c:\windows\temp.

As a last resort, have to tried forcing the install over the previous one?

0 Kudos
harris_s
Level 9

Re: Windows 10 build 1703 and Agent 5.0.5 installation fails

Hi,

I've tried both, downloaded with grant number, which didn't work and also deploying from checked in package on server, still no joy. In using this product for over 8 years I've never had this particular issue. Also tried the KB, no joy either.

0 Kudos
schmiewliski
Level 10

Re: Windows 10 build 1703 and Agent 5.0.5 installation fails

If you turn the firewall off does the agent deploy?

We have 5.0.5 in our environment with no issues at all

0 Kudos
bretzeli
Level 11

Re: Windows 10 build 1703 and Agent 5.0.5 installation fails

Mcafee Agent 5.0.5 should and W10 Creator Update should work but you MAY have to TURN the FIREWALL Short off and UAC?

Maybe make a GPO that does that for Deployment from the EPO Server only.

0 Kudos
harris_s
Level 9

Re: Windows 10 build 1703 and Agent 5.0.5 installation fails

Firewall already off, will try UAC.

0 Kudos
harris_s
Level 9

Re: Windows 10 build 1703 and Agent 5.0.5 installation fails

Tried turning off UAC, with no firewall which goes against the whole principal of AV but still won't deploy. Getting Failed to authenticate with remote system, system error: Access is denied. in server log.

0 Kudos
johnmoe
Level 11

Re: Windows 10 build 1703 and Agent 5.0.5 installation fails

Hmm, you mentioned you deployed from checked in package; what about installed from it?  You can generate a manual installation package by going to System Tree --> New System --> Create and download agent installation package.  Then use that file to do the manual install; that will distribute the ePO server settings, while the one you download directly from McAfee won't have your server settings.

0 Kudos
bretzeli
Level 11

Re: Windows 10 build 1703 and Agent 5.0.5 installation fails

FW/UAC OFF > This is JUST for the Deployment in SBS where you have no GPO in Place for the EPO push of Agents. > For SURE you should turn it on after that. You missunderstand that was only a TRY to get it on the machine.

Framework 5.0.5 is intergrated in EPO Software Manager since this night > Maybe try there to download it newly

0 Kudos