cancel
Showing results for 
Search instead for 
Did you mean: 

Why won't Virus Scan 8.5 install on existing PCs when deployed with ePO 4?

I have a very frustrating issue when trying to roll out VirusScan to a PC already listed in ePO.

I try to deploy the agent manually and then wake the agent up but as this never seems to work I then delete the PC fully from ePO (I select the PC and delete it and and remove agent). As this does not seem to work I then delete the PC again and run the synchronisation with AD to install VirusScan.

I search for the computer name using the Quick System Search and get multiple results for the same PC but the details are empty (no ip address which would indicate the system is not managed). The PC only shows once in the Systems view. I delete the multiple entries (and the agent) and run another Quick System Search the PC is still showing!

I am running ePO 4.0 which has a client task set up as follows:

Target platform:
Windows

Products and components
ePO Agent 3.6.0 / install
VirusScan Enterprise 8.5.0 / install
System Compliance Profiler 2.0.0 / install

Set to run at every policy enforcement, and set to run immediately.

ePo is set to synchronise with AD and when the new PC is detected you can see the McAfee Agent and Updater Setup running
Starting setup...
Validating setup options...
Checking for necessary rights...
Stopping processes if necessary...
Installing files...
Installing registry...
Registering files...
Ensuring COM accessibility...
Installing agent registry...
Installing site list...
Starting UdaterUI...

The window then closes and if you browse to c:\program files you can see MCAFEE\COMMON FRAMEWORK

After a few minutes the folder disappears from the computer and nothing happens.

Am I doing something wrong?

TYPICAL - I have been struggling with this PC all day, and on my final test so I can get notes for this post I find VirusScan has finally installed. I have followed exactly the same steps as before so why did it work this time?? I recall the the Quick System Search finally returned no entries for the PC??

I have read the manuals but none of them give any step by step guides for installing VirusScan via ePO.
Labels (1)
2 Replies

RE: Why won't Virus Scan 8.5 install on existing PCs when deployed with ePO 4?

I ran into this problem one time and it turned out that my DNS scavenging was not functioning properly and multiple machines had multiples DNS entries. Once that was cleared up it worked everytime.

RE: Why won't Virus Scan 8.5 install on existing PCs when deployed with ePO 4?

The scavenging seems to be working ok, and is set to 7 days. I have also checked the DHCP lease time which is set to 8 days.

I was wondering if there may be a corrupted database in ePO listing the PCs?

I have deleted all the "empty" and duplicate entries from the Quick System Search and the list looks much better and some PCs have even installed McAfee with the last synchronisaton.