cancel
Showing results for 
Search instead for 
Did you mean: 
lalons
Level 7

Waking up an agent doesn't work on Windows 7 64 bit

Jump to solution

We have ePO 4.6 deployed to Vista workstations as well as some Windows 7-64 bit workstations.  In the firewall rules, we have added allowed communications for all ports for the frameworkservice.exe.  I can wake up agents installed on Vista machines but not on Windows 7 machines (except when I disable the firewall).  Is there another process I need to add or change for the Windows 7 - 64 bit workstations?

0 Kudos
1 Solution

Accepted Solutions
alexn
Level 14

Re: Waking up an agent doesn't work on Windows 7 64 bit

Jump to solution

Agent wakup communication default port is 8081,Outbound TCP connection.Please confirm in your ePO server settings and then in your firewall.

Agent wake-up communication port: 8081

Alex

0 Kudos
11 Replies
alexn
Level 14

Re: Waking up an agent doesn't work on Windows 7 64 bit

Jump to solution

Agent wakup communication default port is 8081,Outbound TCP connection.Please confirm in your ePO server settings and then in your firewall.

Agent wake-up communication port: 8081

Alex

0 Kudos
lalons
Level 7

Re: Waking up an agent doesn't work on Windows 7 64 bit

Jump to solution

The same GPO firewall rule is applied to ALL systems (both Vista AND Windows 7)  I can wakeup Vista machines only.  The firewall rule allows ALL ports to communicate to frameworkservice.exe.

0 Kudos
alexn
Level 14

Re: Waking up an agent doesn't work on Windows 7 64 bit

Jump to solution

I this case you need to check your client machine, maybe this port is being used by anyother process there or may be blocked by Windows firewall, you may use netsta -a -o command to verify.

0 Kudos
kenobe
Level 10

Re: Waking up an agent doesn't work on Windows 7 64 bit

Jump to solution

Is user account access control enabled?  That might block proper installation of the Agent in the first place.

0 Kudos
alexn
Level 14

Re: Waking up an agent doesn't work on Windows 7 64 bit

Jump to solution

Kenobe, Issue is just about waking up agents, agents are already installed  on windows 7 machines.

Lalona, could you lem me know what error message do you see in Server Task Log?

on 2/14/13 11:58:25 AM CST
0 Kudos
kenobe
Level 10

Re: Waking up an agent doesn't work on Windows 7 64 bit

Jump to solution

Right, but if they're not installed properly they won't wake up.

But I read the original post again and he says it works if he disables the firewall - so must be a Firewall or IPS  rules blocking it.

0 Kudos
McAfee Employee

Re: Waking up an agent doesn't work on Windows 7 64 bit

Jump to solution
But I read the original post again and he says it works if he disables the firewall - so must be a Firewall or IPS  rules blocking it.

I would agree: in fact if disabling the firewall allows the wakeup to work, then it must be the firewall and not IPS. I'm not sure why there would be a difference between Vista and Win7, but I would definitely examine the firewall configuration: logically this must be the cause of the problem.

HTH -

Joe

0 Kudos
twenden
Level 13

Re: Waking up an agent doesn't work on Windows 7 64 bit

Jump to solution

We have similar issues with Windows XP systems using the 4.6X agent but no issues with Windows 7. We already have an exception for frameworkservice.exe in the firewall which listens on Port 8081. The strange issue is Windows XP system quit responding to agent wake-up calls after we went from Agent 4.5.0.1810 to 4.6.0.3122. McAfee Tech support said that we had to put a port exception for TCP 8081 in the firewall.  The weird thing is the XP systems would work with the default firewall exception frameworkservice.exe and agent 4.5.0.1810.  Tried to explain this behaviour with McAfee Tech support but go nowhere.   Since we are not in a AD/Domain environment, I am unable to upgrade 1,000 XP systems to the new 4.6 agent. Instead, I will deploy to systems XP and above. We went to 4.6.0.3122 agent to support Windows 8.

0 Kudos
McAfee Employee

Re: Waking up an agent doesn't work on Windows 7 64 bit

Jump to solution

That's unusual - does disabling the firewall allow wakeups to succeed?

Thanks -

Joe

0 Kudos