cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Level 7
Report Inappropriate Content
Message 1 of 9

VSE installation failure via ePO

Jump to solution

Hi,

I have multiple clients having a problem with installing VSE via ePO after reinstalling McAfee Agents.

My clients use various OS (Windows 7, 8.1, 10, 10 Anniversary), and some of the PCs do not have VSE installed although MA was installed (MA 4.8.0.1938 for Windows 7, 8.1, and MA 5.0.4.283 for Windows 10 or later).

I have deleted MA and VSE(although it was not installed) using MFERemoval100.exe and reinstalled MA with identical version to the one previously installed, and still none of the PC's VSE is not installed.

I have deleted MA and VSE again using MFERemoval100.exe, and reinstalled MA with 5.0.4.283 for Windows 7, 8.1, and 5.0.5.658 for Windows 10 or later. Still none of them got VSE installed.

I have recorded some error logs from McAfee Agent Monitor when clicking 'Update Security' button, as follows:

Verifying VSE880Det.McS.

Downloading VSE880Det.McS.

File VSE880Det.McS could not be verified. Downloading complete file again.

Error occurred while verifying VSE880Det.McS.

Updates were not applied because of a detection script download/verification error:  VIRUSCAN8800.

I have found some discussion articles from this community which have similar problems, however none of them have problem solved.

Does anyone have an idea to solve this problem?

Thanks

1 Solution

Accepted Solutions
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 9 of 9

Re: VSE installation failure via ePO

Jump to solution

Daniel is correct, an update security will not deploy products.  You also need to reboot after running the removal tool.  As Daniel asked, do you have a client task to deploy the products?  Detection script failures typically occur if there are remnants of previous installs remaining (possible lack of reboot after removal tool), higher version installed, corrupt files in repository, or other random causes.  If you are using the proper tasks, have rebooted and everything is working normally that way on other systems, then we would need debug data from failing systems to determine root cause.  See KB82170 for that.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

View solution in original post

8 Replies
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 2 of 9

Re: VSE installation failure via ePO

Jump to solution

Well first of all with "Update Security" you will only trigger Update Tasks like DAT-Updates. This won´t trigger install tasks and this is the reason why it fails.

So do you have a deployment task in your environment for VSE?

Did you assign that task to you Agents?

Can you see your agents trying to run the task?

Regards

Dan

Best regards
Dan
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 3 of 9

Re: VSE installation failure via ePO

Jump to solution

​, Welcome to McAfee community.

I would take a test system, remove Agent and other products gracefully (either via ePO task or from Windows Control panel). You can then try to install agent 5.0.6 and push other packages from ePO. I'm curious, did you reboot the system after using the mferemoval tool? Also, use the tool as a last resort method. Please let us know how it goes.

Highlighted

Re: VSE installation failure via ePO

Jump to solution

i Made this bat file for mcafee clean uninstall, you will need to restart the PC after  executing bat file.. aftert restarting pc deploy agent again, check if the agent services are on and do a agent wake up, after that try to install VSE again.

https://ufile.io/mt65h

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 9

Re: VSE installation failure via ePO

Jump to solution

​, thanks but I have a request. If you don't mind, could you please consider pasting the content of the bat file instead of linking to another site? i think it will benefit the community.

Highlighted

Re: VSE installation failure via ePO

Jump to solution

of course np.

@ECHO OFF

echo ************************************************************

echo *               Mcafee Agent Uninstaller                            *

echo *                                                                                   *

echo ************************************************************

ECHO **Removing McAfee Agent**

ECHO Dont Close, Wait 2 Minutes.

"C:\Program Files\McAfee\Common Framework\x86\FrmInst.exe" /forceuninstall /Silent

timeout /t 30 /nobreak >Null

"C:\Program Files\McAfee\Agent\x86\FrmInst.exe" /forceuninstall /Silent

timeout /t 30 /nobreak >Null

"C:\Program Files\McAfee\Common Framework\FrmInst.exe" /forceuninstall /Silent

timeout /t 30 /nobreak >Null

"C:\Program Files\Network Associates\Common Framework\frminst.exe" /forceuninstall /Silent

ECHO **Removing AntiSpyware**

"C:\Program Files\McAfee\VirusScan Enterprise\scan32.exe" /UninstallMAS

timeout /t 3 /nobreak >Null

"C:\Program Files (x86)\McAfee\VirusScan Enterprise\scan32.exe" /UninstallMAS

timeout /t 3 /nobreak >Null

REM Kill McTray & Trusted Validation

ECHO **Killing processes**

taskkill.exe /f /t /im mctray.exe

timeout /t 3 /nobreak >Null

taskkill.exe /f /t /im mfevtps.exe

timeout /t 3 /nobreak >Null

taskkill.exe /f /t /im masvc.exe

timeout /t 3 /nobreak >Null

taskkill.exe /f /t /im macmnsvc.exe

timeout /t 3 /nobreak >Null

ECHO **Removing VSE**

ECHO Please Wait 2 Minutes

ECHO **Removing VirusScan 8.0**

msiexec.exe /x {5DF3D1BB-894E-4DCD-8275-159AC9829B43} REMOVE=ALL REBOOT=R /q

ECHO **Removing VirusScan 8.5**

msiexec.exe /x {35C03C04-3F1F-42C2-A989-A757EE691F65} REMOVE=ALL REBOOT=R /q

ECHO **Removing VirusScan 8.7**

msiexec.exe /x {147BCE03-C0F1-4C9F-8157-6A89B6D2D973} REMOVE=ALL REBOOT=R /q

ECHO **Removing VirusScan Enterprise 8.8**

msiexec.exe /x {CE15D1B6-19B6-4D4D-8F43-CF5D2C3356FF} REMOVE=ALL REBOOT=R /q

timeout /t 30 /nobreak >Null

REM **Removing McAfee Registry Keys**

ECHO Removing Registry Keys

REG DELETE HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\McShield /f

timeout /t 3 /nobreak >Null

REG DELETE HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\McTaskManager /f

timeout /t 3 /nobreak >Null

REG DELETE HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\mfeapfk /f

timeout /t 3 /nobreak >Null

REG DELETE HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\mfeavfk /f

timeout /t 3 /nobreak >Null

REG DELETE HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\mfebopk /f

timeout /t 3 /nobreak >Null

REG DELETE HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\mfehidk /f

timeout /t 3 /nobreak >Null

REG DELETE HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\mferkdet /f

timeout /t 3 /nobreak >Null

REG DELETE HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\mfetdik /f

timeout /t 3 /nobreak >Null

REG DELETE HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\mfevtp /f

timeout /t 3 /nobreak >Null

REG DELETE HKEY_LOCAL_MACHINE\SOFTWARE\McAfee /f

ECHO **Restarting Computer in 30 Seconds**

ECHO Press a Key to exit

pause

Highlighted
Level 8
Report Inappropriate Content
Message 7 of 9

Re: VSE installation failure via ePO

Jump to solution

What was the resolution for this issue? I am experiencing the same problem. Help!

Highlighted
Level 8
Report Inappropriate Content
Message 8 of 9

Re: VSE installation failure via ePO

Jump to solution

Nevermind, it ended up being missing certs.

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 9 of 9

Re: VSE installation failure via ePO

Jump to solution

Daniel is correct, an update security will not deploy products.  You also need to reboot after running the removal tool.  As Daniel asked, do you have a client task to deploy the products?  Detection script failures typically occur if there are remnants of previous installs remaining (possible lack of reboot after removal tool), higher version installed, corrupt files in repository, or other random causes.  If you are using the proper tasks, have rebooted and everything is working normally that way on other systems, then we would need debug data from failing systems to determine root cause.  See KB82170 for that.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

View solution in original post

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community