cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade failure 5.1.3 to 5.9.1

So I have been working on this upgrade for a few days now.  I have made sure that my account has DBowner and public access in the database. I have changed the SA account and tried that so I know it is not an access to the Database issue.  

I have made sure that my account on the ePO server has admin rights so that it can write to whatever file it needs to.  i continually get to the point where it is trying to install core components and then rolls back.  I have a copy of the logs zipped and ready to upload for review. 

Errors that I see in the logs are:

String detected as needing ANT Conversion removal.
20180725114700 String detected as needing ANT Conversion removal.
20180725114700 String detected as needing ANT Conversion removal.
20180725114701 String detected as needing ANT Conversion removal.
20180725114701 String detected as needing ANT Conversion removal.
20180725114709 Entered SetServiceStartType function.
20180725114709 Setting the StartType for [MCAFEETOMCATSRV510] to [4]

and 

The TomcatLogs folder was not found so skip deleting it.
20180725132705 The orion.properties file was not found so skip deleting it.
20180725132705 The db.properties file was not found so skip deleting it.
20180725132705 Start StreamFileFromBinaryTable function.
20180725132705 Setting MSI query to the following: [SELECT * FROM Binary WHERE Name='MerMod_CommonSetup.DLL']

and 

20180726124537 reg get: 0x2d0\DisplayName (1024)
20180726124537 REG_SZ(1) => McAfee ePolicy Orchestrator 5.1.3 Application Server (53)
20180726124537 Successfully set the PREVIOUSTOMCATSERVICEDISPLAYNAME property to the following: [McAfee ePolicy Orchestrator 5.1.3 Application Server]
20180726124537 reg get: 0x2d0\Description (1024)
20180726124537 REG_SZ(1) => McAfee ePolicy Orchestrator 5.1.3 Application Server services. (63)
20180726124537 Successfully set the PREVIOUSTOMCATSERVICEDESCRIPTION property to the following: [McAfee ePolicy Orchestrator 5.1.3 Application Server services.]
20180726124537 reg close: 0x2d0
20180726124537 End MerMod_GetOldServiceInformation function.
20180726124537 Start MerMod_InstallVariableValidation
20180726124537 End MerMod_InstallVariableValidation
20180726124852 String detected as needing ANT Conversion removal.
20180726124852 String detected as needing ANT Conversion removal.
20180726124852 String detected as needing ANT Conversion removal.
20180726124852 String detected as needing ANT Conversion removal.
20180726124852 String detected as needing ANT Conversion removal.
20180726124901 Entered SetServiceStartType function.
20180726124901 Setting the StartType for [MCAFEETOMCATSRV510] to [4]

Please help.  I see that I can share a link, but how would I upload the log files? 

 

5 Replies
McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 2 of 6

Re: Upgrade failure 5.1.3 to 5.9.1

I would recommend opening a case with McAfee for this.  We do not recommend uploading logs, as they contain customer information that should not be made public on any forums.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Highlighted

Re: Upgrade failure 5.1.3 to 5.9.1

I have opened up a ticket and had to send the log files directly to the agent via email.  I cannot guarentee that they were recieved.  The ticket number is 4-19078414607.

any help is appreciated.  thank you.

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 4 of 6

Re: Upgrade failure 5.1.3 to 5.9.1

I see the logs there, but they are not all the necessary logs.  We need everything in the troubleshoot folder also.  If you run a mer (mer.mcafee.com), it can gather all the necessary logs and that will allow you to upload the resuts to the SR.  When you run the mer, be sure to select epolicy orchestrator as the product.  The advantage of the mer tool is it only needs your email address, even if it isn't a valid one for logging into the service portal to upload it to the case.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: Upgrade failure 5.1.3 to 5.9.1

I have just finished uploading the rest of the required logs. 

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 6 of 6

Re: Upgrade failure 5.1.3 to 5.9.1

Here is the error:

 

BUILD FAILED

D:\Program Files (x86)\McAfee\ePolicy Orchestrator\Installer\core\build.xml:1914: The following error occurred while executing this line:

D:\Program Files (x86)\McAfee\ePolicy Orchestrator\Installer\core\build.xml:1931: The following error occurred while executing this line:

D:\Program Files (x86)\McAfee\ePolicy Orchestrator\Installer\core\build.xml:1685: Network error IOException: Error creating premaster secret.

 

Please see KB87731 for that error.  Also, before attempting the upgrade again, be sure to completely go through kb71825 and possibly also run the pre installation auditor tool.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator