cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to open EPO console after failed upgrade to 5.1.1

I was using EPO 5.1.0 and tried updating it to 5.1.1

The installation failed and the setup rolled back.

After failed update, I can't login to EPO console.

Error:

Error creating bean with name 'core.extensionInstaller' defined in resource loaded from byte array: Cannot resolve reference to bean 'core.db' while setting constructor argument; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'core.db' defined in resource loaded from byte array: Instantiation of bean failed; nested exception is org.springframework.beans.BeanInstantiationException: Could not instantiate bean class [com.mcafee.orion.core.db.base.MfsDatabase]: Constructor threw exception; nested exception is java.lang.IllegalStateException: Cannot initialize database object: check database configuration in /core/config

PluginManager was null!

I tried restarting McAfee services but "McAfee ePolicy Orchestrator 5.1.0 Application Server" and "McAfee ePolicy Orchestrator 5.1.0 Server" fail to start.

I also cannot open the console now.

5 Replies
Reliable Contributor exbrit
Reliable Contributor
Report Inappropriate Content
Message 2 of 6

Re: Unable to open EPO console after failed upgrade to 5.1.1

Moved to ePO for better handling - Moderator

Highlighted

Re: Unable to open EPO console after failed upgrade to 5.1.1

Re: Unable to open EPO console after failed upgrade to 5.1.1

I have the exact same issue and error but the server.xml edit is not my issue.
Was there a fix available for this?

Re: Unable to open EPO console after failed upgrade to 5.1.1

Hello Singh,

can you test the database connection by logging in to https://hostname:8443/core/config

Thanks,

Avinash

Re: Unable to open EPO console after failed upgrade to 5.1.1

I had the same issue with my test epo after my admin account continued to lock out. I realized that the service account I used for my SQL database was linked to this domain admin account.


So I followed Avinash Dasari advice and tried getting to: https://hostname:8443/core/config . Once in here (and with my domain account unlocked) I reset the password in the field to update it, test my connection (which was successful) and applied my change.

In order for it to complete I had to restart the server; afterwards I was back into my epo and my domain account stopped locking out.

Hope this helps anything with a similar issue.

Thanks,

Diego

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community