cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to install McAfee agent

Jump to solution

Hello

Hoping someone can assist.  I have a couple of machines that I cannot push the agent to (version 5.0.2.132), or manually install.  Both machines are running Windows 7, and both are running an older version of the agent (4.0.0.1345).  The ePO reports that the task completed but doesn't install it, and when I download the installation package and run it manually, I get a 'fatal error during installation' message appear.  This is an excerpt of the frminst log on one of the machines:

2016-01-21 14:44:46.578I#5580StubPkg
2016-01-21 14:44:46.579I#5580StubPkgSTART [FramePkg.exe /ForceInstall /Install=Agent /Silent /InstDir="<PROGRAM_FILES_DIR>\McAfee\Agent"]
2016-01-21 14:44:46.579I#5580CommonPkgCreateDirectory (C:\Windows\TEMP\mfeBD96.tmp)
2016-01-21 14:44:47.067I#6544CommonPkgCreateProcess (C:\Windows\TEMP\mfeBD96.tmp\FrmInst.exe, /ForceInstall /Install=Agent /Silent /InstDir="<PROGRAM_FILES_DIR>\McAfee\Agent" /FramePkg /OriginalFramePkg="C:\Windows\FramePkg.exe" /Cleanup="C:\Windows\TEMP\mfeBD96.tmp" /LOGDIR="C:\Windows\TEMP\McAfeeLogs" /EmbeddedUsername="" /EmbeddedDomain="" /EmbeddedPassword="")
2016-01-21 14:44:47I#4616SetupInsSTART [/ForceInstall /Install=Agent /Silent /InstDir="<PROGRAM_FILES_DIR>\McAfee\Agent" /FramePkg /OriginalFramePkg="C:\Windows\FramePkg.exe" /Cleanup="C:\Windows\TEMP\mfeBD96.tmp" /LOGDIR="C:\Windows\TEMP\McAfeeLogs" /EmbeddedUsername="" /EmbeddedDomain="" /EmbeddedPassword=""]
2016-01-21 14:44:47I#4616SetupInsWindows 6.1.7601 Service Pack 1
2016-01-21 14:44:47I#4616SetupInsRunning as System account, therefore no UI
2016-01-21 14:44:47I#4616msiFixInsFinding agent MSI product code
2016-01-21 14:44:47I#4616msiFixInsGot MSI product code {757A7F5D-F9A1-4DC5-8738-C0A31C658BC8}
2016-01-21 14:44:47I#4616msiFixInsFinding agent MSI version
2016-01-21 14:44:47I#4616msiFixInsGot agent MSI version 4.00.0012
2016-01-21 14:44:47I#4616msiFixInsNothing to fix for this agent version
2016-01-21 14:44:47I#4616SetupInsAttempting to perform a setup operation
2016-01-21 14:44:47E#4616FilerInsError trace:
2016-01-21 14:44:47E#4616ThreadIns [Main thread]->
2016-01-21 14:44:47E#4616SetupIns [Attempting to perform a setup operation]->
2016-01-21 14:44:47E#4616FilerIns  Missing MA data path
2016-01-21 14:44:47I#4616SetupInsAttempting to reset VTP cache...
2016-01-21 14:44:47I#4616SetupInsFailed resetting VTP cache, VtpUtilsControlCreate returned error 126. (This is ok if vtp was not already installed)
2016-01-21 14:44:47I#4616SetupInsError disabling MA SelfProtection: 126
2016-01-21 14:44:47I#4616caShrLbInsSOFTWARE\Network Associates\TVD\Shared Components\Framework is not present
2016-01-21 14:44:47I#4616SetupInsLegacy installed=0
2016-01-21 14:44:47I#4616SetupInsInstalling version=5.0.2.132
2016-01-21 14:44:47I#4616SetupInsHigher version installed=0
2016-01-21 14:44:47I#4616SetupInsdwRes= 2
2016-01-21 14:44:47I#4616SetupInsExisting Install Path=C:\Program Files (x86)\McAfee\Common Framework
2016-01-21 14:44:47I#4616SetupInsExisting Data Path=C:\ProgramData\McAfee\Common Framework
2016-01-21 14:44:47I#4616SetupInsExisting setup program=C:\Program Files (x86)\McAfee\Common Framework\frminst.exe
2016-01-21 14:44:47I#4616SetupInsLangInRegistry=[0409]
2016-01-21 14:44:47I#4616OptSetInslegacyupgrade=0
2016-01-21 14:44:47I#4616OptSetInsForceInstall=1
2016-01-21 14:44:47I#4616caShrLbInsSOFTWARE\Network Associates\TVD\Shared Components\Framework is not present
2016-01-21 14:44:47I#4616OptSetIns ForceInstall: 1 legacyupgrade: 0 MA5xUpgrade: 0
2016-01-21 14:44:47I#4616OptSetIns/forceinstall ignored, the agent is not installed
2016-01-21 14:44:47I#4616SetupInsC:\Windows\SysWOW64\msiexec.exe /i "C:\Windows\TEMP\mfeBD96.tmp\MFEagent_x64.msi" ADDLOCAL=Main,Agent,Svc_x64 TRANSFORMS=:1033.mst /q REBOOT=R /l+*v "C:\Windows\TEMP\McAfeeLogs\MFEagent.msi.2016.01.21.14.44.47.log" INSTALLDIR="C:\Program Files\McAfee\Agent" SITELISTINFO="C:\Windows\TEMP\mfeBD96.tmp" PRESERVEREPOSITORIES=True USELANGUAGE="0409" FRMINSTLOGFILE="C:\Windows\TEMP\McAfeeLogs\FrmInst_WHEDEV005"
2016-01-21 14:44:48.577I#6544StubPkgRunning as a service, therefore not waiting for installation to complete
2016-01-21 14:44:48.577I#5580StubPkgEND 0

If anyone can assist I would be most grateful.

Thanks

Paul

1 Solution

Accepted Solutions

Re: Unable to install McAfee agent

Jump to solution

I'm fairly sure you can't upgrade from 4.0.0 to 5.x.

2016-01-21 14:44:47I#4616OptSetIns

/forceinstall ignored, the agent is not installed

I noticed this line.  I'm guessing it can't even see that an existing Agent is installed. 

If the syntax is the same on the 4.0 Agent, run, FrmInst.exe /forceuninstall to remove the Agent, and then deploy the new Agent fresh. 

8 Replies
PhilR
Level 12
Report Inappropriate Content
Message 2 of 9

Re: Unable to install McAfee agent

Jump to solution
2016-01-21 14:44:47I#4616SetupIns

Error disabling MA SelfProtection: 126

Unable to uninstall the old agent due to Access Protection policies?

Re: Unable to install McAfee agent

Jump to solution

Hi PhilR

Yeah, I noticed that, but I've performed exactly the same procedure on every other machine in our organisation (over 170) without issue.  We upgraded from an older version of the ePO, and the agent push procedure has a checkbox to force over the top of old versions. I don't know why it would work on every other machine and not these two.

Thanks

Paul

PhilR
Level 12
Report Inappropriate Content
Message 4 of 9

Re: Unable to install McAfee agent

Jump to solution

Maybe policies are not applying properly on the affected boxes?

Try a manual agent removal and see what happens.

Cheers,

Phil

Re: Unable to install McAfee agent

Jump to solution

I'm fairly sure you can't upgrade from 4.0.0 to 5.x.

2016-01-21 14:44:47I#4616OptSetIns

/forceinstall ignored, the agent is not installed

I noticed this line.  I'm guessing it can't even see that an existing Agent is installed. 

If the syntax is the same on the 4.0 Agent, run, FrmInst.exe /forceuninstall to remove the Agent, and then deploy the new Agent fresh. 

Re: Unable to install McAfee agent

Jump to solution

Hi tkinkead

I've upgraded from version 4.0.0.1345 to 5.0.2.132 170 times without issue via the ePO.  But I'll try force removing the agent as you and PhilR have suggested and report back as to success.  Thanks for suggestions so far.

Cheers

Paul

meforum
Level 10
Report Inappropriate Content
Message 7 of 9

Re: Unable to install McAfee agent

Jump to solution

uh ... I'm pretty sure that Agent 4.0 is not supported on Win 7 ... so I would recommend uninstall 4.0 and install 5.x.

Re: Unable to install McAfee agent

Jump to solution

Hi meforum

That's what I'm trying to do!

I can't get access to the machine at the moment as it's in constant use.  As soon as I can I'll report back on attempting to manually uninstall the agent and replacing with version 5.0.2.132.

Cheers

Paul

Re: Unable to install McAfee agent

Jump to solution

I can confirm that running FrmInst.exe /forceuninstall and then pushing the agent again from the ePO worked perfectly.  Many thanks for all assistance.

Paul