cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to install Agent Handler

Jump to solution

Hi

I have had problems trying to install an Agent Handler in our DMZ.; I get the "Server did not detect a compatible ePo server..." error when installing.

All the required ports are open as confirmed by our security team. I contacted McAfee phone support and I wasl told to configure the install parameters for the server as follows:

ePO Server: <our SQL server>,1433

ePO Server Port: leave as default 8443

I questioned using the SQL server but I was told this is way it is done, it failed. I did try using our ePO server without port 1433 and with port 8443 but it still failed.

From the server in the DMZ I  tried telnetting to both the SQL server on port 1433 and our ePO server on port 80 and both failed.

I then telnetted to our WSUS server on port 80 and it worked, also from the DMZ.

The host file on the Agent Handler server in the DMZ has the details for both the SQL server and the ePO server.

So I decided to try installing the Agent Handler on the internal network as a way of testing the install and I still get the same error.

Internally, from a client pc I can telnet to the ePO server on port 80.

Internally, from the ePO server I can telnet to the SQL server on port 1433.

My question is, if I can telnet to the ePO and SQL server why does the installation of the Agent Handler on the internal network fail?

Cheers

Chris

1 Solution

Accepted Solutions

Re: Unable to install Agent Handler

Jump to solution

Hi Tao

At last I have a solution!! Seems there was a rule missing from our firewall and this was correctd and I was able to telnet to the ePO and SQL servers.

I still couldn't connect to the SQL server on install, kept telling me "it couldn't connect with the current credentials"

The account I was using to connect to the SQL server was a dbo on the ePO database so it had rights however, to get it to connect I had to give the account dbcreator rights to the database.

I assume that is because it had to write tothe database as part of the AH install; I have left it at that even after the install. I may try and remove the dbcreator right to see if it still connects okay.

Tanks for your help.

Cheers

Chris

View solution in original post

4 Replies
Reliable Contributor tao
Reliable Contributor
Report Inappropriate Content
Message 2 of 5

Re: Unable to install Agent Handler

Jump to solution

Can you post the AH error log?  Also, not sure if you have this already but here's the Agent Handler Config:

http://www.mcafee.com/us/resources/white-papers/wp-agent-handler-epo-4-5.pdf

Default Port Setup

AHPorts.PNG

If this information was helpful or has answered your question, please select Accept as Solution. This will assist other memebers

Re: Unable to install Agent Handler

Jump to solution

Hi Tao

Thanks for the reply and my apologies in getting back to you so late.

I have managed to install AH on the internal network. Turns out I was using the wrong version - 4.05 instead of 4.06. The ports have been opened as per the diagram and according to the security team, the telnet tests are going from the server I am trying to install AH on in the DMZ to the firewall but are not getting through. One of the security tchs is coming to see me today to check out the firewall I know of plus one or two others that are also involved tah I was not aware of.

I will keep this discussion updated.

Cheers

Chris

McAfee Employee hem
McAfee Employee
Report Inappropriate Content
Message 4 of 5

Re: Unable to install Agent Handler

Jump to solution

If the installation is failing then please post the log files if you can.

Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?please select Accept as Solution in my reply and together we can help other members?

Re: Unable to install Agent Handler

Jump to solution

Hi Tao

At last I have a solution!! Seems there was a rule missing from our firewall and this was correctd and I was able to telnet to the ePO and SQL servers.

I still couldn't connect to the SQL server on install, kept telling me "it couldn't connect with the current credentials"

The account I was using to connect to the SQL server was a dbo on the ePO database so it had rights however, to get it to connect I had to give the account dbcreator rights to the database.

I assume that is because it had to write tothe database as part of the AH install; I have left it at that even after the install. I may try and remove the dbcreator right to see if it still connects okay.

Tanks for your help.

Cheers

Chris

View solution in original post

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community