cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to find valid repository

Jump to solution

Hello ,

We have a problem with updating our systems. from start of this problem it was about 3-4 users and after 24h it is more than 50.

 

Error message is " Unable to find valid repository " .

 

We are using 

1) Endpoint Security Platform 10.6.1.1724    /  Endpoint Security Web Control 10.6.1.103   / Endpoint Security  10.6.1.1777  / Endpoint Security Firewall 10.6.1.1394

2) Windows Server 2012 R2 Datacenter

3)EePolicy Orcgestrator 5.9.1

 

all ports that should be opened ,  are opened from users to server. (443 too ).

Telnet is working  from that kind of systems to server.

 

 

 

MCScript Deploy log .

 

2019-10-29 15:26:16 I #3632 downloader Downloading file from https://IP:443/Software/SiteStat.xml?hash={ebe62764-fa3e-11e9-2c1f-8bdd7300e4df} to C:\Windows\TEMP\SiteStat.xml with timeout 18000
2019-10-29 15:26:16 I #3632 network URL(https://IP:443/Software/SiteStat.xml?hash={ebe62764-fa3e-11e9-2c1f-8bdd7300e4df}) request, failed with curl error 7, Response 0, Connect code 0,
2019-10-29 15:26:16 I #3632 curl text 21 Closing connection 0

 

I am waiting for mcafee support about 24hrs and there is no answer . 

So if you had such problem and know solution please share it .

Labels (1)
1 Solution

Accepted Solutions
cdinet McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 25 of 32

Re: Unable to find valid repository

Jump to solution

I looked at your case and your case owner is correct on the dll injections.

2019-10-31 15:15:49.764 mfemactl(11084.1412) mfemactl.Info: The process <C:\PROGRAM FILES\MCAFEE\AGENT\X86\MCSCRIPT_INUSE.EXE>(10912) was blocked from accessing('CREATE' (1)) <AAC_OBJECT_SECTION:C:\WINDOWS\SYSWOW64\PGPLSP.DLL> via the rule <Sanitize selected MA Processes>

McScript is being blocked due to the pgplsp.dll not being trusted, which is why things work when you remove that encryption software.  That dll is related to your encryption software.  So, the solution is this - follow KB88085

That kb will tell you how to get the .cer file from that dll (hopefully there is one).  Once you get that, let us know.  Let us know also if the file doesn't have a certificate.  Here is how to find that cert.

Go to properties of the dll file, then go to digital certificates.  If it doesn't have that tab, then there is no cert.  If it does have the tab, then if there is more than one digital cert, you will need to click on each one, then view certificate and export that cert for each.  

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

View solution in original post

31 Replies
Thussain McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 32

Re: Unable to find valid repository

Jump to solution

Thank you for posting your query

As per the logs you have shared looks like the client machines are not able to download the SiteStat.xml file. 

The error message is request, failed with curl error 7, Response 0, Connect code 0,

As per KBA

The error could be due to client machines trying to connect to a proxy server or host 

CURLE_COULDNT_CONNECT (7) Failed to connect to host or proxy
Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Re: Unable to find valid repository

Jump to solution

Yes i see that problem but there is no connection problems .

 

Telnet is working , ports are opened from proxy and from firewall too .

On some systems it works great but some systems have such kind of problem .

LKS McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 32

Re: Unable to find valid repository

Jump to solution

What happens when you try to download the below URL from browser.

https://IP:443/Software/SiteStat.xml?hash={ebe62764-fa3e-11e9-2c1f-8bdd7300e4df}

You should be able to download XML file. If not, then there is an issue.

Was my reply helpful?

If you find this post useful, please give it a Kudos! Also, please don't forget to select "Accept as a Solution" if this reply resolves your query!

Re: Unable to find valid repository

Jump to solution

So i can download xml file from link manually .

I can't understand what is the problem . >>

Thussain McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 32

Re: Unable to find valid repository

Jump to solution

When you start the update or deployment process, scriptMain would invoke the ScriptMain in agent's UpdateMain.Mcs to check if this is a normal update, rollback or deployment task

  1. During the update process the first file or component McAfee Agent tries to download is the Sitestat.XML file
  2. Once this is downloaded successfully it downloads the Catlog.z file
  3. Then it tries to get the Pkgcatalog.z of the product for whom the update was triggered
  4. All files are verified by hash from replica.log
  5. The detection script is downloaded and executed.
  6. The detection script performs necessary checks and notifies McAfee Agent to proceed with the update or deployment.
  7. Then the Install script of the product is download which tells the script engine to download the required files, verifies them and starts the installer.

In your case, I am not sure why you are not able to download Sitestat.xml. You will need to verify that info first

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!
LKS McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 7 of 32

Re: Unable to find valid repository

Jump to solution

do you see any specific information in mfemactl log under <programdata/mcafee/agent/log>

The data in the mfemactl log will show entries like:

o    C:\PROGRAM FILES\MCAFEE\AGENT\X86\MCSCRIPT_INUSE.EXE>(7208) was blocked from accessing('CREATE' (1)) <aac_object_section:c:\windows\syswow64\bmnet.dll <br="">
</aac_object_section:c:\windows\syswow64\bmnet.dll>

 

Re: Unable to find valid repository

Jump to solution

So i have such errors here .

 

 

1) Line 72: 2019-10-29 16:15:25.329 mfemactl(436.208) mfemactl.Info: The process <C:\PROGRAM FILES\MCAFEE\AGENT\X86\MACOMPATSVC.EXE>(5040) was blocked from accessing('CREATE' (1)) <AAC_OBJECT_SECTION:C:\WINDOWS\SYSWOW64\PGPLSP.DLL> via the rule <Sanitize selected MA Processes>

 

 

2)Line 79: 2019-10-29 16:17:46.096 mfemactl(436.7812) mfemactl.Info: The process <C:\PROGRAM FILES\MCAFEE\AGENT\X86\MCSCRIPT_INUSE.EXE>(8556) was blocked from accessing('CREATE' (1)) <AAC_OBJECT_SECTION:C:\WINDOWS\SYSWOW64\PGPMAPIH.DLL> via the rule <Sanitize selected MA Processes>

 

3)

Line 176: 2019-10-29 16:53:35.775 mfemactl(436.224) mfemactl.Info: The process <C:\WINDOWS\SYSTEM32\SVCHOST.EXE>(904) was blocked from accessing('WRITE, DELETE' (a)) <AAC_OBJECT_PROCESS:C:\PROGRAM FILES\MCAFEE\AGENT\MACMNSVC.EXE> via the rule <Protect MA Processes>

 

4)

Line 183: 2019-10-29 16:53:37.744 mfemactl(436.224) mfemactl.Info: The process <C:\WINDOWS\SYSTEM32\SVCHOST.EXE>(904) was blocked from accessing('WRITE, DELETE' (a)) <AAC_OBJECT_PROCESS:C:\PROGRAM FILES\MCAFEE\AGENT\X86\MACOMPATSVC.EXE> via the rule <Protect MA Processes>

 

 

and many many others .

 

Thanks for your quick answers. 

 

LKS McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 9 of 32

Re: Unable to find valid repository

Jump to solution

Lot of third party .DLL injection in McAfee process.

  • Run the sysprep tool first to see if there are any DLLs that it finds and trusts.

https://kc.mcafee.com/corporate/index?page=content&id=KB89860&_ga=2.124471309.646745185.1572248891-1...

Also can you what are these DLL files.

PGPLSP.DLL and PGPMAPIH.DLL

Was my reply helpful?

If you find this post useful, please give it a Kudos! Also, please don't forget to select "Accept as a Solution" if this reply resolves your query!

Thussain McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 10 of 32

Re: Unable to find valid repository

Jump to solution

May I know what is the version of McAfee Agent installed?

Have you tried reinstalling the MA

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!
You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community