cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to find valid repository(clients fail to get updates through Agent)

Hello everyone!

           I have a problem for clients DAT  to update with the following error:Unable to find valid repository. The client can receive the EPO's policy and task properly.

          The server.log on the EPO records the following error:

20160614003734I#05428NAIMSERVSending props response for agent FUNDAPP, policy files attached (Policy\Server.xml)
20160614003734I#05428NAIMSERVSigning agent response package with key DtQUSIGdD3iw//5zpBskbduF9JuixBQMeNUwJEx2Pf4=
20160614003734I#05428MOD_EPOepo request processed, rc=0, session ID=148249, session time=359ms
20160614003856I#04108NAIMSERVWake up agent on DNS name fundAPP...
20160614003859E#04108NAIMSERVnaSPIPE.cpp(320): Failed to find IP address for fundAPP
20160614003859I#04108NAIMSERVWake up agent on NetBIOS name FUNDAPP...
20160614003901E#04108NAIMSERVnaSPIPE.cpp(320): Failed to find IP address for FUNDAPP
20160614003901I#04108NAIMSERVWake up agent on IP address x.x.x.x...
20160614003902I#05428NAIMSERVReceived [FullProps] from FUNDAPP:{A2FD6EAA-FBAC-4223-8CC0-9ABB81EDB2DF}
20160614003902I#05428NAIMSERVProcessing agent props for FUNDAPP(A2FD6EAA-FBAC-4223-8CC0-9ABB81EDB2DF)
20160614003902I#05428NAIMSERVAgent meta-data out of date, 336121 > 0; resending.
20160614003903I#05428NAIMSERVFound 1 tasks assigned to node FUNDAPP
20160614003903I#05428NAIMSERVSending props response for agent FUNDAPP, policy files attached (Policy\Server.xml)
20160614003903I#05428NAIMSERVSigning agent response package with key DtQUSIGdD3iw//5zpBskbduF9JuixBQMeNUwJEx2Pf4=
20160614003903I#05428MOD_EPOepo request processed, rc=0, session ID=148250, session time=437ms
20160614003958I#05428NAIMSERVReceived [PropsVersion] from ZSYH:{04E092E5-51C2-42F6-83DD-934D32A1D204}
20160614003958I#05428NAIMSERVUsing attached Props.xml props from node ZSYH
20160614003958I#05428NAIMSERVProcessing agent props for ZSYH(04E092E5-51C2-42F6-83DD-934D32A1D204)

      I also try to modify the hosts file,but it is not an effective method.Who can help me solve the this problem? thanks!

3 Replies

Re: Unable to find valid repository(clients fail to get updates through Agent)

Hi,

how you're updating the clients by using a task or manual update.

please check the windows firewall status and also try to update manually.

cheers

jagadeesh

Re: Unable to find valid repository(clients fail to get updates through Agent)

thanks jagadeesh!

I am updating the clients by using a task and manual update.The windows firewall status also disabled。

Re: Unable to find valid repository(clients fail to get updates through Agent)

What version of the Agent and ePO do you have? Are there any recent changes you've done to either? This does sound like a firewall blocking communication because you can get policy and task but not wake up calls. Will the agent check in once it's hit its mandatory check in time?

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community