cancel
Showing results for 
Search instead for 
Did you mean: 
florfilla19
Level 7

Unable to find a valid repository when lauching client tasks after server reboot

Hi All.

We encounter something really god-awful with our epo console.

The problem occurs after each reboot of the server (for example for MS patch), or simply stop/restart mcafee services due to crash of apache or tomcat.

Client tasks are failling due to 'unable to find a valid repository' after logging into console after reboot.

To solve this problem we are obliged to run a replication task after each restart.

Does anyone have any ideas on this irritating problem?

Running ePO 5.1.3 with lastest hotfix installed on a physical Windows 2012 R2 server.

0 Kudos
7 Replies
McAfee Employee

Re: Unable to find a valid repository when lauching client tasks after server reboot

​, have you double checked that everything in your "Distributed Repositories" look to be in order? THen also please check the agent repository policies. What is being applied to your clients, are your clients able to reach the specific repository they are told to go via agent policy. you can rebuild a repository but this sounds more of a client/communication issue to me.

0 Kudos

Re: Unable to find a valid repository when lauching client tasks after server reboot

Yes we too have similar issue. DAT failed- unable to find repository.

Rebuild repository but stil issue not resolved. But this issue is affected to only few clients and that too servers.

ePO 5.1.3 ( with latest Java & directory vulnerability hotfix)

McAfee Agent 5.0.5.658

VSE 8.8 Patch 9 and Hotfix

DXL 3.1.0

DLP 11.0

HIPS 8 Patch 9 & hotfix

TIE 2.0.1.188

We tried to roll back VSE 8.8 From patch 9 to patch 8 but issue not resolved!!!!!!! Logged case and working with support.

So far no positive results on their findings.

florfilla19
Level 7

Re: Unable to find a valid repository when lauching client tasks after server reboot

Hi, we have approx the same setup here.

ePO version and product used.

Please let me inform of you case issue.

Last time when we submit a case for this issue we have the basic response 'Its as design..."

0 Kudos
kfordham281
Level 7

Re: Unable to find a valid repository when lauching client tasks after server reboot

Anyone ever get a resolution? We have the same issue with some Endpoint Security clients. Also running ePO 5.1.3. In the upgrade from VSE to ENS, a very small number of clients stop installing DAT updates and get the "unable to find a valid repository" message. They continue to get this message and so far we are unable to resolve this issue. So far only 3 out of 950+ devices have gotten this issue.

0 Kudos

Re: Unable to find a valid repository when lauching client tasks after server reboot

we upgraded to ePO 5.9 with latest Hotfix but still problem exists. we identified this problem occurs when ePO server, AH/repository server had reboot.
Only specific Nodes.
McAfee agent 5.0.6 Release Notes has DAT update issue resolve.
Dont know either our issue resolve or not. This week planning to upgrade.

If anyone findout solution. please advise.

0 Kudos
kfordham281
Level 7

Re: Unable to find a valid repository when lauching client tasks after server reboot

We were able to capture one of the systems with this issue and Agent 5.0.6 did not resolve it for us.

I still have an open case with McAfee but we haven't made much progress on it yet.

0 Kudos

Re: Unable to find a valid repository when lauching client tasks after server reboot

At present issue resolved in our ePO console.

After Oct-2017 MS Patching server reboot time, I followed below reboot sequence

1. DB Server (Wait till all service are up & running)

2. Agent Handler (Wait Event parser service is started and Application service will be starting status)

3. ePO server ( After reboot, make sure event parer service successfully started.)

Now check Agent handler application service changed from STARTING to Running)

Do wakeup Agent and select force policy & task update.

All agents are successfully updated DAT and reporting successfully.

Our McAfee current specs

McAfee Agent 5.0.5| McAfee ePO 5.9.0.732 |McAfee DLP 11.0.2.32

McAfee VSE 8.8 Patch 9| McAfee HIPS 8.0 Patch 9 |McAfee ENS for Linux 10.2.0.1098

McAfee security for sharepoint 3.5 | TIE for VSE - 1.2.112

TIE server 2.1.0.338 | DXL Broker 3.1.0.607 | DXL Client 3.1.0.580

ePO server installed on MS cluster.

Windows server 2012

SQL Server 2012 sp3 (CU10)

0 Kudos