cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to Edit Client Task

Using ePO 4.0 (Patch 6 Build 1333).  Server recently upgraded from ePO 3.6x

After I create a client task for a On-Demand Scan for VS 8.7, when it returns to the list of tasks for the current group, under the Action options the choices are "view" and "delete" and both of them are grayed out.  It will not let me edit or delete the task.  Creating the same task for 8.5 works fine, and I have the option to edit or delete the task.  I am able to edit and delete the policies for 8.7 just fine.  I am using the global 'admin' account.

2 Replies
Highlighted

Re: Unable to Edit Client Task

Dear Shakomatic,

I came accross a similar issue just recently. The problem in my case was that in the ePO 4.0 database in the table "dbo.EPOSOFTWARE" one entry for the product code VIRUSCAN8700 (indicating VSE 8.7) was wrong.

In the example below you can see that here the values for PlatformsSupported and ExtensionsInstalled for the entry with the language "040c" are wrong.

          

AutoID ProductCodeSoftwareNameProductVersionProductFamilyLanguagePlatformsSupportedExtensionInstalledExtensionsContext
40VIRUSCAN8700 VirusScan Enterprise8.7.0TVD040aWNTW:4:0:4|WNTS|W2KW|W2KS|WXPHE|WXPW|WXPS|WVST|WVSTS|WNT7WTRUEVIRUSCAN8700
41VIRUSCAN8700 VirusScan Enterprise8.7.0TVD040cW2KW:5:0:3|WXPW:5:1:1|WXPHE:5:1:1|WXPS:5:2|WVST|WVSTSFALSEVIRUSCAN8700

In your case it might be a different entry that is causing the same problem. You will need to identify which entry is wrong and then you can use the SQL script below to correct the entries. If the language various please replace the last entry in the command '040c' with the according details.

UPDATE [dbo].[EPOSoftware] SET PlatformsSupported = 'WNTW:4:0:4|WNTS|W2KW|W2KS|WXPHE|WXPW|WXPS|WVST|WVSTS|WNT7W', ExtensionInstalled = 1 WHERE ProductCode = 'VIRUSCAN8700' AND Language = '040c'

HTH,

Rene

Re: Unable to Edit Client Task

That seems logical.  But before I got your message I removed the VS87 extensions and package from ePO and added back in and then it fixed the problem.  Thanks for the reply.

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community