cancel
Showing results for 
Search instead for 
Did you mean: 

Unable deploy Agent via ePO or install manually

Jump to solution

Hi there.

When I'm trying to deploy agent, I have "In Process" stack on 0%.

I event tried via URL and have "Unable to download files".

And I don't know how to troubleshooting it. Because, 2 weeks ago I did it without any troubles and I don't know what's changed rigth now.

1 Solution

Accepted Solutions

Re: Unable deploy Agent via ePO or install manually

Jump to solution

I just restarted ePO and it began working.

5 Replies
Reliable Contributor sunshinebg
Reliable Contributor
Report Inappropriate Content
Message 2 of 6

Re: Unable depoy Agent via ePO or install manually

Jump to solution

In what environment is ePO, internet faced or local network?

Can you check also McAfee ePO Server Public DNS name and agent handler too.

McAfee Certified Product Specialist: (ePO), (ENS), (HiPs)

Re: Unable depoy Agent via ePO or install manually

Jump to solution

Local network.

I doesn't have "McAfee ePO Server Public DNS" item via "Server Settings".

Agent Handler Setting > %NAME% where "Published DNS Name" and "Published IP Address" are empty.

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 4 of 6

Re: Unable deploy Agent via ePO or install manually

Jump to solution

See KB56386 for environmental requirements for deploying an agent.  On the epo server, the server log will show a push agent failed (using the deploy agent method).  The error will look like this:

push agent failed, err=1326 or some other number - most common is 53.  To determine exactly what that error means, go to a command prompt and type this:

net helpmsg 1326 or the actual error number and it will tell you what that means.  1326 is bad password, 5 is access denied, 53 is unable to find network path.

Basically you have to be able to (from the epo server itself) get to the admin$ share of the client, copy the file there, then execute it remotely.  All the elements of the kb above are required for all that to work. 

If that succeeds but still fails on the client side, then you would need to look at local client logs to see why.  The windows\temp\mcafeelogs directory will have the install logs for the agent for any failures. 

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: Unable deploy Agent via ePO or install manually

Jump to solution

I just restarted ePO and it began working.

Highlighted
McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 6 of 6

Re: Unable deploy Agent via ePO or install manually

Jump to solution

You might have had some server initialization errors in the server log before you restarted the server.  That can cause the repository to not be available for the clients to pull files.  If the issue occurs again, please open a ticket with McAfee so we can determine why the server is getting hung.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community