cancel
Showing results for 
Search instead for 
Did you mean: 
skh
Level 8
Report Inappropriate Content
Message 1 of 10

Status lights are not shown for "Run Client Task Now"

Jump to solution
We have a number of ePOs but only one is at level 5.10.0 (Build 2428). On this ePO the status lights for "Run Client Task Now" remain at grey, even though the job is accepted, started, and completed. We thought that some port was not open between the clients and the ePO, but that does not seem to be the case. The clients report their status normally. What could be the issue here?
1 Solution

Accepted Solutions
skh
Level 8
Report Inappropriate Content
Message 10 of 10

Re: Status lights are not shown for "Run Client Task Now"

Jump to solution

Yes, the port just got opened, and all our problems are gone. Smiley Happy

It took some time for us to identify the root cause, because the port has been open before, and nobody thought to check it again.

9 Replies
McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 2 of 10

Re: Status lights are not shown for "Run Client Task Now"

Jump to solution

Does the server log show any errors when trying to send the task?  That is located in the directory where epo is installed - db\logs.  It would not show any status if it has not been able to reach the client to send it the task.  Do the clients show that it received the task?  Do you have update2 applied to the 5.10 server?  There is an issue with the internal dbcleanup task not running that the update fixes, which can cause datachannel failures, which is how the run client task now is sent. 

Also keep in mind that using the RCTN is not designed to do mass deployments or large amounts.  That can also lead to possible datachannel failures.  When a task is sent that way, the datachannel communication attempt is kept open until a completion is received and if it can't get there, it can stay in an in progress state indefinitely.  See KB85013

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

skh
Level 8
Report Inappropriate Content
Message 3 of 10

Re: Status lights are not shown for "Run Client Task Now"

Jump to solution

Thanks for your reply. There are no errors in the logs when trying to send the task, and the task is performed normally. For instance, when I test this by sending a wake up task to a single client, the client immediately responds and the Last Communication time is updated, but the ePO only shows the first grey light.

I do not think that I have update2 applied, because I do not know which build corresponds to update2, but I doubt that we have it. I am going to update the system as soon as possible.

I think it is likely that this is a datachannel failure, but I doubt that it is because the datachannel is overloaded, because as I said, it fails with just a single client, and there are 53 clients on the server at this moment.

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 4 of 10

Re: Status lights are not shown for "Run Client Task Now"

Jump to solution

If you don't have update2 applied, it could definitely cause something like that and related to datachannel, even though you only have a few systems.  There is an issue where the dbcleanup task (internal) fails to run and that keeps the queues cleaned out and keeps things moving.  The update fixes that.  You can tell if you have it 2 ways - run the update and it will tell you if it is already applied or not.  If it shows applied, you might want to remove it and reinstall.  There have been times where one part of the update failed to apply, but showed successful overall. 

The other way is to go to server settings, server information and it will show under the version whether you have any update applied or not. 

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Reliable Contributor User91972758
Reliable Contributor
Report Inappropriate Content
Message 5 of 10

Re: Status lights are not shown for "Run Client Task Now"

Jump to solution

HI @skh

My team and I were in the same boat yesterday. We have patch 2 applied to our ePO server running 5.10 and RCTN was all grayed out even though the tasks were going fine.

 

I ended up having to log into our ePO server last night and restart the services:

- McAfee Event Parser

- McAfee Web Application

- McAfee server

 

and ran a task just a moment ago and it seemed like it cleared up this issue. If you have a moment where you can do that too, I think it might work.

 

Hope this helps!

skh
Level 8
Report Inappropriate Content
Message 6 of 10

Re: Status lights are not shown for "Run Client Task Now"

Jump to solution

Unfortunately, it will take some time before we can update the ePO. We are running our ePOs in clusters, and Update2 cannot be applied to clusters Smiley Sad

 

But we are told that Update3 with cluster support is on the way ...

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 7 of 10

Re: Status lights are not shown for "Run Client Task Now"

Jump to solution

Update 3 is now released, so please apply that.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

skh
Level 8
Report Inappropriate Content
Message 8 of 10

Re: Status lights are not shown for "Run Client Task Now"

Jump to solution

We installed Update 3 yesterday, but unfortunately, nothing changed.

But we have found another clue: We noticed that the status lights appeared for a single client, and this client was the only one that did not go through an agent handler in order to reach the ePO. We then changed the handler rules so that a couple more machines that can reach the ePO directly did so without a handler, and the status lights showed up as normal.

We now believe that it is the loss of a firewall opening of port 8444 from the handlers to the ePO that is the cause of the problem. There are also a lot of communication errors to be found on the agents, and they also disappear when not going through a handler.

Port 8444 will be opened as soon as network finds the time, and then i'll report back.

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 9 of 10

Re: Status lights are not shown for "Run Client Task Now"

Jump to solution

That will do it.  Run client task now uses datachannel communication, which requires that the agent handlers are able to talk to the epo server application server.  They use 8444 for that.  So you would see a lot of datachannel communication failures in the ah server logs as well as agent logs on the clients.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

skh
Level 8
Report Inappropriate Content
Message 10 of 10

Re: Status lights are not shown for "Run Client Task Now"

Jump to solution

Yes, the port just got opened, and all our problems are gone. Smiley Happy

It took some time for us to identify the root cause, because the port has been open before, and nobody thought to check it again.

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community