cancel
Showing results for 
Search instead for 
Did you mean: 
epoNovice
Level 9

Server to Agent Communication Not Working

Jump to solution

Hey All, If anyone can help here you will be a Legend for all time.

Our Encryption Activation was not working without manual intervention and after troubleshooting we have found the Agent Wakeup calls arn't either.

PC's are only connecting to EPO when the commnuincation is initiated from the Agent on the PC.

When a agent wakeup is attempted the server task log dosn't show any info about the machine trying to connect so not even sure if the task is actually initiating.

The Server.log does show error for some machines:  Error - XXXXXXXXXXXXX.com:8081, network error was 10060

Products:  EPO 4.6.3, MA 4.8, Agent wakeup using deafult port of 8081.

Checks:

1)  The policy for the agents has wakeup agents selected.

2)  There are no Desktop Firewall issues (have even unistalled HIPS off machines to test)

3)  Can ping machines from server via netbios, IP and FQDN

4)  Can TelNet to machines from Server

Tests: 

1)  This issue even occurs even when trying an agent wakeup to the agent on the EPO server so there shouldn't be any vlan or subnet issues.

Anyone have anything I can try????

Cheers

0 Kudos
1 Solution

Accepted Solutions
epoNovice
Level 9

Re: Server to Agent Communication Not Working

Jump to solution

Hey Laszlo - Think we have it now.

We needed to restart the Tomcat Services to:  Clear all unfinished data channel tasks....I have no idea what these are but it seems to have worked.  Also unsure if we will need to do this as regular (maybe quaterly) maintenacne task on the server.

Cheers

0 Kudos
4 Replies
ulyses31
Level 16

Re: Server to Agent Communication Not Working

Jump to solution

Hi, if you are able to telnet these computers to port 8081 maybe you're having DNS trouble.

As you posted ePO tries to connect to computers as xxxxx.com:8081 and I suppose your computers doesn't have a .com extension.

If you try to open oin a web browser the http://xxxx:8081 url of a computer can you see its log?

0 Kudos
epoNovice
Level 9

Re: Server to Agent Communication Not Working

Jump to solution

Hey Laszlo, thanks for your comments.

The xxx.com was just the FQDN blanked out.

The I can view the agent logs from EPO through the web browser...going back to the server.log it seems it is not even registgering wake up calls most of the time when they are initiated.

We are trying wireshark now...seems the server is attempting a handshake but failing somewhere...although this dosn't explain why its not being recorded in the log when intiated.

0 Kudos
ulyses31
Level 16

Re: Server to Agent Communication Not Working

Jump to solution

As McAfee just posted McAfee Agent 4.8 with patch 1 you could try to add the new epoagentmeta extension to ePO and deploy new version to ypour computers and see if the errors still persist.

0 Kudos
epoNovice
Level 9

Re: Server to Agent Communication Not Working

Jump to solution

Hey Laszlo - Think we have it now.

We needed to restart the Tomcat Services to:  Clear all unfinished data channel tasks....I have no idea what these are but it seems to have worked.  Also unsure if we will need to do this as regular (maybe quaterly) maintenacne task on the server.

Cheers

0 Kudos