cancel
Showing results for 
Search instead for 
Did you mean: 
twenden
Level 13
Report Inappropriate Content
Message 1 of 2

Question about using Microsoft SCCM Configuration Manager to check for systems that need ePO Agent deployed to them

Jump to solution

Our systems folks are playing around with the Microsoft SCCM configuration manager. The plan is to deploy a set of base software to endpoints that include the virus software and ePO agent. However, they want to know how to check for systems that already have the ePO agent installed and which is communicating to the ePO server. Are there any registry keys that they can check for that would indicate a endpoint that is in managed mode and communicating to the ePO server.

1 Solution

Accepted Solutions
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 2

Re: Question about using Microsoft SCCM Configuration Manager to check for systems that need ePO Agent deployed to them

Jump to solution

Take a look at HKLM\SOFTWARE\Wow6432Node\Network Associates\TVD\Shared Components\Framework\

AgentMode -- 1 is managed, 0 is not managed. 

This will be slightly different on a 32-bit machine. This one should be true for 5.x Agents, but on one of my machines with 4.8.0.1500, I don't have this value, so you might check...

HKLM\SOFTWARE\Wow6432Node\Network Associates\ePolicy Orchestrator\Agent\

AgentGUID should only report a value if it is managed already, but you may want to check on an unmanaged 4.8, since I don't have one to check on.

1 Reply
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 2

Re: Question about using Microsoft SCCM Configuration Manager to check for systems that need ePO Agent deployed to them

Jump to solution

Take a look at HKLM\SOFTWARE\Wow6432Node\Network Associates\TVD\Shared Components\Framework\

AgentMode -- 1 is managed, 0 is not managed. 

This will be slightly different on a 32-bit machine. This one should be true for 5.x Agents, but on one of my machines with 4.8.0.1500, I don't have this value, so you might check...

HKLM\SOFTWARE\Wow6432Node\Network Associates\ePolicy Orchestrator\Agent\

AgentGUID should only report a value if it is managed already, but you may want to check on an unmanaged 4.8, since I don't have one to check on.