Showing results for 
Search instead for 
Did you mean: 
Level 7
Report Inappropriate Content
Message 1 of 3

Problems with ePO 5.3 / Agent 5.0.2

Hello, I'm having some difficulty with our ePO server (v 5.3) and the agent (v 5.0.2) that I'm hoping to get some guidance on how to troubleshoot.

We currently use agent version 4.8 and everything works perfectly. I've recently checked in 5.0.2 to the evaluation branch and pushed it to a few clients, and that's where the fun begins. My test case is as follows:

Windows Server 2012 R2, fully patched

I can push agent 4.8 from the ePO server, the client runs my initial tasks to install VS 8.8 and HIP 8.0, and all policies are applied correctly.

However, when I push agent 5.0.2, the trouble starts. I've tried upgrading the agent while VS and HIP are installed, I've also tried starting from scratch (no agent or software). In both cases, the agent installs but no client tasks will run and policies stop having any effect (e.g., my managed VS update task disappears at the first checkin with the 5.0.2 agent). If I manually install VS, still my policies never take. ePO reports that the agent and VS are installed.

If I push the 4.8 agent back to the client, everything starts working again.

I don't see any errors in the agent monitor or the client logs, but maybe I'm not looking in the right place. I'm not an expert with ePO but have a working understanding. Hopefully I've just missed something simple. Please let me know if I need to provide any additional info to troubleshoot this. Any and all help is appreciated.



2 Replies
Reliable Contributor twenden
Reliable Contributor
Report Inappropriate Content
Message 2 of 3

Re: Problems with ePO 5.3 / Agent 5.0.2

We had issues with policies not working with McAfee Drive encryption and Agent 5.0.2. This was fixed with agent Have you tried this newer agent version?

Level 7
Report Inappropriate Content
Message 3 of 3

Re: Problems with ePO 5.3 / Agent 5.0.2

As far as I know, I'm using the latest agent I have access to: I don't administer our mcafee account - we're a government site and are just told which license number to use but I can't actually log into the support portal to download patches and things that way.

Edit: To clarify, I am using the newest version listed in the software manager which is

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community