cancel
Showing results for 
Search instead for 
Did you mean: 

Problems Installing Agent Handler 4.5

I am having an issue installing the agent handler.  I keep getting the error "Setup did not detected a compatible ePO server with the specified parameters." 

Systems

ePO Server

ePO 4.5 build 937

SQL 2005 on same server

OS is 2003 server on VMware ESXi 4.1

Agent Handler Server

OS is 2008 Std. on VMware ESXi 4.1

Troubleshooting step I have taken so far.

Ping by name from both servers.

From AH server telneted to ePO server on ports 1433, 8443, 8005 all successful.

Recopied AgentHandler folder from ePO4.5 P3 folder on the ePO server.

Tried multiple gobal admin accounts including SQL admin account.

Can open ePO console webpage form AH server.

Attached is the install log made my running the following command from the AgentHandler directory in a command prompt

msiexec /I agenthandler.msi /L*v Install.log

it creates the log in the AgentHandler folder

TIA

13 Replies
Highlighted
McAfee Employee hem
McAfee Employee
Report Inappropriate Content
Message 2 of 14

Re: Problems Installing Agent Handler 4.5

Could you please verify the version showing in the server.ini file on the ePO server? Is it listed 4.05.0000. If then please correct the version there, restart the ePO services then try to run AH installer.

MSI (c) (D4:4C) [13:51:45:093]: Windows Installer installed the product. Product Name: McAfee Agent Handler. Product Version: 4.05.0000. Product Language: 1033. Installation success or error status: 1602.

Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?please select Accept as Solution in my reply and together we can help other members?

Re: Problems Installing Agent Handler 4.5

I changed the server.ini file in \Program Files\McAfee\ePolicy Orchestrator\DB from version=9.5.0.937 to version=9.05.0000.

Still receive the same error

Thanks

McAfee Employee hem
McAfee Employee
Report Inappropriate Content
Message 4 of 14

Re: Problems Installing Agent Handler 4.5

Correct version should be 4.5.0.937.

Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?please select Accept as Solution in my reply and together we can help other members?

Re: Problems Installing Agent Handler 4.5

Sorry, the way I read your first post was to change it to 4.05.0000.  The version was 4.5.0.937 before I changed it. 

Also, I meant 4. not 9 in the pervious post

McAfee Employee hem
McAfee Employee
Report Inappropriate Content
Message 6 of 14

Re: Problems Installing Agent Handler 4.5

Sorry if my response prompted you to incorrect way.

Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?please select Accept as Solution in my reply and together we can help other members?

Re: Problems Installing Agent Handler 4.5

Not a problem. 

We are back to the original post.

I really appreciate the help

Re: Problems Installing Agent Handler 4.5

Top, for one more try.

robrod
Level 9
Report Inappropriate Content
Message 9 of 14

Re: Problems Installing Agent Handler 4.5

This KB should help: https://kc.mcafee.com/corporate/index?page=content&id=KB71468&pmv=print&viewlocale=en_US

Corporate KnowledgeBase ID:  KB71468
Last Modified:  March 23, 2011

Problem

The ePolicy Orchestrator (ePO) 4.5 Agent Handler installation fails on a remote system, displaying the following error:

McAfee Agent Handler - Installation Wizard
“Setup did not detected a compatible ePO server with the specified parameters.“

Cause

This issue occurs because the version of Data1.cab file from the Agent Handler installation folder is a different version from the ePO installation files versions.

Solution

Install the Agent Handler using the files from AgentHandler folder that correspond to the ePO server version that was installed.

Example: If you installed the ePO 4.5 Patch 4, install the Agent Handler using the files from AgentHandler folder for ePO 4.5 Patch 4.

Re: Problems Installing Agent Handler 4.5

After reading that KB I recopied the AgentHandler folder from ePO4.5 P3 folder on the ePO server.

still having the same issue

Message was edited by: mknutson on 4/2/12 11:20:26 AM CDT
More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community