cancel
Showing results for 
Search instead for 
Did you mean: 
oyebof
Level 7
Report Inappropriate Content
Message 1 of 9

New ePo Repository not replicating and Clients not pulling from nearest repository

Good day all,

Please , i have a critical problem with McAfee setup on my network. My organization span across 5 countries. So i created repositories for each country. But i am having the following issues:

1. Only 2 out of the 5 of the repositories has been failing on replication. Notwithstanding that the replication is done overnight when there are no traffic on the network.

2. The clients in countries of the successful repositories are not pulling update from their repository but rather trying to pull from the central ePo.

3. Trying to move up the repository on each client via Edit Auto update list has not been successful as the movement revert back after closing the setting window.

8 Replies

Re: New ePo Repository not replicating and Clients not pulling from nearest repository

1. You have to look at the replication task to see which problem are having these repositories (timeout...)

2. You have to edit the McAfee Agent policy for these computers or groups and at the "repositories" tab select which will be the main repository for these machines or groups. Also be sure to check the "Use order in repository list" box


oyebof
Level 7
Report Inappropriate Content
Message 3 of 9

Re: New ePo Repository not replicating and Clients not pulling from nearest repository

Please, how do i go about the 2 recommendations.

Thanks.

Re: New ePo Repository not replicating and Clients not pulling from nearest repository

For ePO 4.0:

- To have a look at the replication task go to Reporting->Server Task Log->look for the replication task and click on it to see the details; once you have clicked on it you will see a link that you can click on again to see the task details and errors found on replication.

- To change the repository order we first assume that you have created a different group for each country in your ePO's system tree; so select one of these groups then click on the policies tab and select McAfee Agent. You will only see a general policy for McAfee Agent so click on "edit assignment"->break inheritance->new policy and edit the repositories tab to choose the repository order for this group (be sure to check the "use order un repository list" box). Save your new policy and send a wake up agent call to all the computers in this group (or if you don't want to make a wake up call they will update automatically the new policy in an hour). Do the same with the other groups creating a new McAfee Agent policy each time.

For ePO 4.5:

it's the same except that the server task log is located at Menu->automation->server task log

oyebof
Level 7
Report Inappropriate Content
Message 5 of 9

Re: New ePo Repository not replicating and Clients not pulling from nearest repository

I have checked the replication task, all i could see is begining replication to the repository. no other details. But in previous ones it will show 25% complete then replication failed.

Secondly, I have edited the policy and the client repository order now reflect the repository in the country as top most. But when we tried update now it will not be able to pull from the repository and will be able from the Master repository.

Please, what can I do.

Thanks a lot.

Re: New ePo Repository not replicating and Clients not pulling from nearest repository

If the distributed repository hasn't been replicated then the computers there will go back to the master repository to update themselves.

As for the replication task you should be able to see the job details and se what has happened to these repositories (wrong credentials, timeout...)

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 7 of 9

Re: New ePo Repository not replicating and Clients not pulling from nearest repository

If you definitely want to prevent client machines from updating from the master, set the master repository to Disabled in the agent policy - don't just move it to the bottom of the list.

Regards -

Joe

oyebof
Level 7
Report Inappropriate Content
Message 8 of 9

Re: New ePo Repository not replicating and Clients not pulling from nearest repository

Thanks the clients pulling issue has been resolved but i am still having issues with replication to some of the new repositories. find below the error generated in one of the repository:

Failed to upload file Current\EPOAGENT3000\Install\0409\FramePkg.exe to site 193.1.0.47, error code 121 ( The semaphore timeout period has expired. ), will retry

What is the work around for sites with low bandwidth ? Is it possible to copy files from a repository to another for the first replication , so the repository can subsequently do the incremental replication.

oyebof
Level 7
Report Inappropriate Content
Message 9 of 9

Re: New ePo Repository not replicating and Clients not pulling from nearest repository

Thanks the clients pulling issue has been resolved but i am still having issues with replication to some of the new repositories. find below the error generated in one of the repository:

Failed to upload file Current\EPOAGENT3000\Install\0409\FramePkg.exe to site 193.1.0.47, error code 121 ( The semaphore timeout period has expired. ), will retry

What is the work around for sites with low bandwidth ? Is it possible to copy files from a repository to another for the first replication , so the repository can subsequently do the incremental replication.