cancel
Showing results for 
Search instead for 
Did you mean: 

Moving hard drive with ePO and VSE installed to another laptop -- no updates

I will sometimes have to move a hard drive to another laptop to facilitate repair of the first laptop.  When the hard drive is moved to another computer, McAfee stops receiving updates.  I normally have to delete ePO and VSE and run the clean up tools and then reinstall to reestablish communication to the ePO server to allow dat file updates.  Is there an easier way?

Thanks

Andrea

9 Replies
alexn
Level 14
Report Inappropriate Content
Message 2 of 10

Re: Moving hard drive with ePO and VSE installed to another laptop -- no updates

Here from ePO you mean McAfee Agent on that laptop?

Re: Moving hard drive with ePO and VSE installed to another laptop -- no updates

Apologies, yes, I meant the agent on the laptop.

alexn
Level 14
Report Inappropriate Content
Message 4 of 10

Re: Moving hard drive with ePO and VSE installed to another laptop -- no updates

Okay,

One thing more, does your agent communicates with your ePO server on new laptop after replacing HD?

Regds

Re: Moving hard drive with ePO and VSE installed to another laptop -- no updates

Additional information:

From Agent log:

2013-03-12 09:25:54.359    I    #9212    imsite        Upload from: C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130075719534070000_2357712522.spkg

2013-03-12 09:25:54.359    I    #9212    imsite        Upload response target: C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130075719543590000_653663744.spkg

2013-03-12 09:25:54.421    I    #9212    imsite    NaInet library returned code == 13

Communication is occurring, but the server is not sending the updates

Re: Moving hard drive with ePO and VSE installed to another laptop -- no updates

This is not an unusual occurance.  I have done the hard drive swap numerous times and it happens every time.  The only suggestion I was able to get from support was to remove the agent and VSE and reinstall.  The cleanup tools have to be run to remove registry entries or the same thing happens on reinstall. 

I am guessing that a signature is created using the hardware.  The signatures do not match when the hardware is changed, so the server won't communicate.  The signature is most probably in the registry, hence the need for the cleanup tools.

Re: Moving hard drive with ePO and VSE installed to another laptop -- no updates

Only error I've found on the server side is when I attempted a push to overright the agent and reinstall.

20130312085705    I    #01392    NAIMSRV     Pushing agent install, source:Current/EPOAGENT3000/Install/0409, target system: <device-name> target path: <PROGRAM_FILES_DIR>\McAfee\Common Framework

20130312085706    I    #01392    NAIMSRV     Copy C:\Windows\TEMP\mfe2076033476.tmp\FramePkg.exe to \\<device-name>\ADMIN$\FramePkg.exe Successfully

20130312085706    X    #01392    NAIMSRV     agntinst_PushInstall failed to connect to remote registry, error 53

20130312085706    X    #01392    NAIMSRV     InstallAgentNT() failed to determine target NT processor type, assuming x86 processor architecture

20130312085706    X    #01392    NAIMSRV     NAIMServInst service does not exist, installing service

20130312085706    I    #01392    NAIMSRV     Push Agent Install parameter: FramePkg.exe /ForceInstall /Install=Agent /Silent /InstDir="<PROGRAM_FILES_DIR>\McAfee\Common Framework"

20130312085707    I    #01392    NAIMSRV     Push Agent Installation Program to <device-name> was successful

Replaced actual device name with <device-name>

I set the logging level higher than default to produce a more verbose log.

alexn
Level 14
Report Inappropriate Content
Message 8 of 10

Re: Moving hard drive with ePO and VSE installed to another laptop -- no updates

Workaround : 1

Remove sitlist. from (Default )C:\ProgramData\McAfee\Common Framework  and restart Mcafee framework service and post your resuilts.

Regds

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 9 of 10

Re: Moving hard drive with ePO and VSE installed to another laptop -- no updates

Hello Andrea,

I'm assuming that the "new" laptop (the one that the hard drive is moved to) has a different IP address assigned through DHCP.  It would also have a different MAC address.  The only 2 things that would likely be static at this point would be the system Hostname and the McAfee Agent GUID (assigned when the Agent is installed).  I have to see if i can find any documentation on the process that ePO uses to identify the machine, but I do know that often if several of these main system attributes are changed, ePO will have trouble locating the system through the network.  This could also be an issue with DNS not resolving the hostname to the correct IP address, or ePO attempting to use the "last known" IP address for that system.

However now I have just read your last update and I'm seeing that ePO does appear that it's able to connect to the UNC path \admin$ on the machine, so it is finding the machine.  I see the Remote Registry error that you're talking about.  When you attempted this agent install, did the agent successfully get installed on the target machine?

Re: Moving hard drive with ePO and VSE installed to another laptop -- no updates

Hi Andrea

If you are planning to move a working communicating HDD o another laptop then this will not work..

Look for the instructions on how to delete the GUID from the image on the new laptop.. Delete the entry on the Epo server for the old connection.. When the laptop is rebooted it will connect up to EPO and generate a new GUID... All Goood...

Regards

Bruce