cancel
Showing results for 
Search instead for 
Did you mean: 

Moved ePO database and now having issues

Hi,

First, I'll start with the background.

I have a server 2003 Virtual Machine running SQL Server 2005 Express. It has an OS partition and a data partition. I built this server to store my SUS and ePO databases. During my frantic install (another facility hosed my previous ePO and SUS server) I had SQL put the databases on the OS partition, which was not my ultimate goal.

I built another server 2003 Virtual Machine to run ePO 4 on. I installed ePO without a hitch, had it store the db's on my SQL Express server. After I got it running and my policies imported, I realized I had the databases on the wrong partition.

I used SQL Management Studio Express to stop the service and detach the ePO database. I then copied the database to the correct partition, and reattached it using the Management Express app.

I then remoted to the ePO server, opened ePO and logged in with no problems. ePO itself works fine, I can update the repository, do an AD sync and have my agents pull updates with no issues.

All of the Queries I run show no results for any date after the date that I moved the db's. Using these queries is pretty helpful for me.

Has anyone else ran into a problem like this?

Thanks,

Nate
Tags (1)
3 Replies

RE: Moved ePO database and now having issues

Have you tried to change your SQL settings on the ePO server?

Try to access https://your_epo_server:8443/core/config and change any wrong config of your SQL server there

RE: Moved ePO database and now having issues

Nope. I shouldn't have to. The database name didn't change and since I reattached it like the original db (same server, same database name), it should be fine.

I reinstalled Patch 4 and I'm starting to get results in the queries. Who knows why that fixed the problem, but it seems as though it did!

RE: Moved ePO database and now having issues

Strange thing but happy to see it works now wink