cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7
Report Inappropriate Content
Message 1 of 5

Missing stored keyset

Jump to solution

Hello, everyone.
We have the ePo Server 5.9.1 and VSE 8.8 Patch 14 in use. The ePo Server runs on a Windows Server 2012R2.
In the event log of the server I get the following error message in the Windows Security Log about 8 times per second: Event ID 5061, Audit Failure, Source: Microsoft Windows security auditing.
The certificate displayed in the event log (issuer CN=AH_CA_SERVERNAME, OU=AH, O=McAfee) is from the ePo.
Certutil -RepairStore My "xx xx..." reports: Missing stored keyset.

Does anyone have an idea how I can solve the problem with the ePo certificate?

Apparently the private key for the certificate is missing.

 

1 Solution

Accepted Solutions
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 5

Re: Missing stored keyset

Jump to solution

Hello @rbl ,

As per the logs shared, below article will help you resolve the issue.

Failed to send HTTP request. Error=12186 (Apache not connecting to tomcat)
Technical Articles ID: KB92703

Was my reply helpful?
If you find this post useful, Please give it a Kudos! l Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Yash T

View solution in original post

4 Replies
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 5

Re: Missing stored keyset

Jump to solution

Does the server log (located in db\logs where epo is installed) show any certificate errors?  Do you know when the issue started and if anything changed at all?

 

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Highlighted
Level 7
Report Inappropriate Content
Message 3 of 5

Re: Missing stored keyset

Jump to solution

Unfortunately, I can't say when the problem started and there were no changes I can think of now.
In the server log there are many HTTP errors like this one:

"NAIMSERV server.cpp(637): Failed to send request, err=0x80004005, HTTP status code=0
20200522090823 E #12532 NAIMSERV server.cpp(1035): Error sending data channel message to application server
20200522090823 E #12532 MCUPLOAD SecureHttp.cpp(984): Failed to send HTTP request. Error=12186 (12186)"

 

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 5

Re: Missing stored keyset

Jump to solution

Hello @rbl ,

As per the logs shared, below article will help you resolve the issue.

Failed to send HTTP request. Error=12186 (Apache not connecting to tomcat)
Technical Articles ID: KB92703

Was my reply helpful?
If you find this post useful, Please give it a Kudos! l Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Yash T

View solution in original post

Highlighted
Level 7
Report Inappropriate Content
Message 5 of 5

Re: Missing stored keyset

Jump to solution

Thanks for the help. 

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community