cancel
Showing results for 
Search instead for 
Did you mean: 

Migrate From EPO 4.5.5 to 5.1

Hi There,

This is my first post in Mcafee Community.

I have a project assigned which involves migrating from our current EPO 4.5 Server to EPO 5.1.

The 4.5 Server is running on Windows 2008 R2 and has SQL 2008 installed.

I have a seperate dedicated Server for EPO 5.1 with a different host name and a different IP and would like to install EPO 5.1 on it and then transfer my systems and policies accross to the new Server.

Once everything is transferred over to the new EPO 5.1 Server, the old 4.5 Server will be decommissioned.

Is there any guide available to do this?

Thanks,

DS

3 Replies
djjava9
Level 11
Report Inappropriate Content
Message 2 of 4

Re: Migrate From EPO 4.5.5 to 5.1

Have you thought about using the transfer systems functionality built into epo?  Instructions on page 115 https://kc.mcafee.com/resources/sites/MCAFEE/content/live/PRODUCT_DOCUMENTATION/24000/PD24808/en_US/...

Re: Migrate From EPO 4.5.5 to 5.1

I am on the same boat.....our EPO is 4.5.0.937 (patch3) running on Windows server 2003 and DB on another dedicated SQL box running 2008 R2.

Do we need to upgrade to 4.6 first or is there a direct upgrade path to the latest version?

help is appreciateed

Re: Migrate From EPO 4.5.5 to 5.1

Just think of this as two parts 1. Upgrade 2. Backup and restore to a new location.

You can either upgrade then backup-restore or backup-restore then upgrade. The transfer systems functionality only addresses moving agents to another ePO not policies. I don't think there is a direct upgrade path from 4.5, so if running 4.5, you'd have to upgrade it to 4.6, then to 5.1.

So in a nutshell:

1. Backup a copy of your database & ePO IAW the backup/restore KB

2. Perform inplace upgrade

3. Restore the database to the new server (if necessary)

4. Run the ePO installer on the new system

https://kc.mcafee.com/corporate/index?page=content&id=kb66616

https://kc.mcafee.com/corporate/index?page=content&id=KB76739

For most users who don't change defaults / security settings it will be a breeze. However if you have, there are a few potential installer issues you may run into (outside of the upgrade KB)...

1. If you've changed default SSL authentication methods or ports, the installer could fail to authenticate

2. IP/Hostname renaming can cause hickups, ensure your hosts file is updated if necessary

3. Make sure 8.3 settings are enabled (and if changed rebooted before attempting anything)

4. WinTrust\Trust Providers key is not set to be extra restrictive