cancel
Showing results for 
Search instead for 
Did you mean: 

Mcafee agent error - Failed to upload package to ePO Server

I am running ePO 4 patch 3 for few weeks but encounter problem as below:

Agent fail to update record in ePO. I found that there is eorro like "Failed to upload package to ePO Server", "Failed to get acknowledgement from Server" and "NaInet library returned code == -14"

It happens on few PCs. and it seems it cannot be fixed even I remove and reinstall the agent. sad
11 Replies
tonyb99
Level 13
Report Inappropriate Content
Message 2 of 12

RE: Mcafee agent error - Failed to upload package to ePO Server

RE: Mcafee agent error - Failed to upload package to ePO Server



Thanks tonyb99!!

Actually, all PCs are in a computer Lab. But all the agent were installed after the ghost process. Thus the AgentGUID should be different and I can see all PCs report to ePO server when they firstly complete the installation. However, while running for few weeks, some PCs cannot update record to ePO.

BTW, the IP of the PCs may be changed as some PCs may turn off for few days as the IP expire time is 8 hours. Will this cause the problem?
tonyb99
Level 13
Report Inappropriate Content
Message 4 of 12

RE: Mcafee agent error - Failed to upload package to ePO Server

could do..

try clearing the keys as specified in the article and see

RE: Mcafee agent error - Failed to upload package to ePO Server



Tony - do you know if it needs all three or just ANY of the items to be duplicated ?

Reason I'm asking is that the IP address one will surely happen normaly where clients use DHCP to allocate IP's ?

Jim
tonyb99
Level 13
Report Inappropriate Content
Message 6 of 12

RE: Mcafee agent error - Failed to upload package to ePO Server

I only clear the guid and mac keys when resetting a dup guid but clearing all 3 is worth trying if there is an issue.

RE: Mcafee agent error - Failed to upload package to ePO Server



Seems sensible - but do you think that the noted problem would apply (not updating properly) if a Machine was switched off for long enough for another PC to get allocated the same IP via DHCP ? Also which client is it that get's affected ?

Thanks,

Jim

RE: Mcafee agent error - Failed to upload package to ePO Server



Yes. It's what I worry about too.

Does anyone know, how ePO server handle cases like this? will the agent update the new IP and report to the server?

RE: Mcafee agent error - Failed to upload package to ePO Server

Hi,
the Ip is reported when it changes.
I see this on our VPN clients sometime our notebook got the right Adresse and some times 10.10..... in epo

RE: Mcafee agent error - Failed to upload package to ePO Server



VPN clients are a "special case" problem as it really depends on how the VPN Clinet handles the IP Address Translation - some VPN clients use the same MAC address for all connections....

...anyone know what's "supposed to" and "does" happen in the non-VPN arena ?

Jim