cancel
Showing results for 
Search instead for 
Did you mean: 
Hentie
Level 7
Report Inappropriate Content
Message 1 of 12

McScript_InUse.exe using 100% of CPU

On Monday when I arrived back in the office after the weekend, reports came in that systems are running at 100% util. Looking we found that McScript_InUse.exe was running at 100% util, killing the McScript_InUse.exe process caused framework.exe to jumped up and it started to run at 99%.

Searching around I found a KB on lowering the priority of Framework. This done the CPU was still running high.

Continuing searching I found a couple of references to exclusions and priority threats on VirusScan. To rule out VirusScan I uninstalled it on 2 servers. Problem still persisted.

By the lunch time it became apparent that it's on all systems within the company, about 1700 systems.

I deleted all client tasks from the ePO console to rule out tasks and deleted the task folder in the agent directory.

At 14:20 the McScript_InUse.exe dropped down to 20% and then stopped completely. The following morning at 8am it all stated up again and was running at 100% util.

Teusday Framework and McScript_InUse.exe were stopped throughout the company, VrusScan is still running. The company was unable to function due to this problem.

I support multiple companies with the same versions, but only this company have this problem.

Versions being used in the company.

     ePO server - 4.5.0 Build 937

     ePO Agent - 4.5.0.1499

     VirusScan - 8.7.0.570 with Patch 3

11 Replies
McAfee Employee JoeBidgood
McAfee Employee
Report Inappropriate Content
Message 2 of 12

Re: McScript_InUse.exe using 100% of CPU

Please open a case with support for this... we've seen a couple of cases like this and are getting the engineering team to look at them.

Thanks -

Joe

Hentie
Level 7
Report Inappropriate Content
Message 3 of 12

Re: McScript_InUse.exe using 100% of CPU

Case was opened on Monday already. Still searching for solution.

Reliable Contributor SCtbe
Reliable Contributor
Report Inappropriate Content
Message 4 of 12

Re: McScript_InUse.exe using 100% of CPU

I have almost similar case opened for this, but VSE is not instaled and FrameworkServer consumes 100% CPU for couple of hours after performing first ASCI.

This also happen on MA 4.5 P1 (b 1499)

McAfee Employee JoeBidgood
McAfee Employee
Report Inappropriate Content
Message 5 of 12

Re: McScript_InUse.exe using 100% of CPU

Is it mcscript_inuse.exe that's using all the CPU, though? If not then it's likely to be a different issue...

Thanks -

Joe

Hentie
Level 7
Report Inappropriate Content
Message 6 of 12

Re: McScript_InUse.exe using 100% of CPU

McScript_InUse.exe uses 99-100% of CPU. If I "End Task" the McScript_InUse.exe process, Framework starts using 80-99% and re-launches McScript_InUse.exe whereupon McScript_InUse.exe start using 100% again and Framework returns to 0%.

on 2010/09/08 2:48:59 PM
dolchy
Level 7
Report Inappropriate Content
Message 7 of 12

Re: McScript_InUse.exe using 100% of CPU

I've had reports of some computers freezing with McScript_InUse.exe at 100%. This occurred while the computers attempted to update the daily DATs while an On-Demand Scan was running.

Versions being used in the company.

     ePO server - 4.5.0 Build 851

     ePO Agent - 4.5.0.1499

     VirusScan - 8.5.0.781 with Patch 8

I've now changed the DAT Update schedule to exclude the OD Scan schedule.

Hentie
Level 7
Report Inappropriate Content
Message 8 of 12

Re: McScript_InUse.exe using 100% of CPU

I uninstalled McAfee on 2 servers. Installed only the ePO Agent and McScript_InUse.exe started running high again.

runcmd
Level 10
Report Inappropriate Content
Message 9 of 12

Re: McScript_InUse.exe using 100% of CPU

Is this something that struck "out of the blue" or only since you installed Patch 3 in this environment?  There is a similar thread in the VSE forum which (whether legitimately or illegitimately) points the finger at Patch 3...

https://community.mcafee.com/message/148116

I'm getting ready to deploy Patch 3 in our environment and reading these types of threads is making me nervous. 

dolchy
Level 7
Report Inappropriate Content
Message 10 of 12

Re: McScript_InUse.exe using 100% of CPU

PS. I'm using VSE 8.5 P8 on wiorkstations. This happened out of the blue. As a precaution, NO DAT updates are scheduled while computers are running weekly OD Scans.

I have 400 Windows Servers running VSE 8.7 P3 for almost 3 months now and no issues so far. Had to upgrade to this version on servers because of Win 2008 64 bit systems.

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community