cancel
Showing results for 
Search instead for 
Did you mean: 

McAfee ePO App Server Crashing on Repo Pulls

We have a 4.5 Patch 3 ePO server that stopped pulling updates from internal http server.  In looking at the logs on both the IIS server and the ePO server it was evident that the files were successfully being downloaded, but they were not being imported into the ePO server.   The Update Repository task was hanging at 100%.  It trying to troubleshoot we deleted the existing DAT from the ePO server and attempted another pull.  However, now the ePO Application Server service crashes on each attempt and no errors are logged up until the time of the 7031 error in the System log.

All other 4.5 and 4.0 servers are successfully pulling updates from the IIS server just fine.  Any ideas on what may have caused the server to stop importing updates and more importantly how to keep the service from crashing?

TIA,

Ron

5 Replies
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 6

Re: McAfee ePO App Server Crashing on Repo Pulls

Do you have a file called mclf_tomcat5 in the ePO install folder?

Thanks-

Joe

Re: McAfee ePO App Server Crashing on Repo Pulls

Strangely there isn't.  I see the file on our lab server but not on the one having the issue.  I'm guess it's important and needs to be recreated somehow?

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 6

Re: McAfee ePO App Server Crashing on Repo Pulls

Not in this case, no - I've seen a couple of cases where this file becomes corrupt and needs to be recreated, but if it's not present then it shouldn't be causing a problem...

Can you try copying the file from your lab server to the failing one and try the pull again - I'd be interested in the results.

Thanks -

Joe

Re: McAfee ePO App Server Crashing on Repo Pulls

Unfortunately, due to the restrictions where I work I can't copy from lab.  How can this file be recreated?

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 6

Re: McAfee ePO App Server Crashing on Repo Pulls

Unfortunately it can't be - it would be automatically recreated as part of a successful pull. Catch-22   I don't think the absence of the file is the problem - I was just interested to see if replacing it would have any effect.

I'd suggest opening a case with support for this one as it's likely to be beyond the scope of the forum.

Regards -

Joe