cancel
Showing results for 
Search instead for 
Did you mean: 

McAfee Autoupdate

Jump to solution

Is there any way of modifying the McAfee AutoUpdate task on the client computers from EPO server. In the help it says

From the ePolicy Orchestrator console, go to Systems | System tree | Client Task

. Select an existing update task or to create a new task, click New Task

, then from the Type list, select Update (McAfee Agent) and click Next

Problem is when I select new task there is no Update (McAfee Agent) task. There is a Autoupdate task for groupshield but not for McAfee Agent. There is a product update task but then the clients have 2 update tasks.

I have version 4.5.0 1499 of the McAfee agent and I have installed 4.5.0.171 of McAfee Angent Extensions installed.

Dr

.

1 Solution

Accepted Solutions
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 8

Re: McAfee Autoupdate

Jump to solution

It's in a fairly unusual location   It's part of the VirusScan policy: under User Interface policies, there's a checkbox for "Disable default autoupdate task schedule."

HTH -

Joe

7 Replies
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 8

Re: McAfee Autoupdate

Jump to solution

I'm afraid not - the only option from within ePO is to disable the default autoupdate task (the assumption being that you've created another update task, thereby leaving you with just one functional task that is under your control.)

Note that this is a one-way operation - once you've disabled the default task you can't re-enable it, but that's not really a problem.)

Regards -

Joe

Re: McAfee Autoupdate

Jump to solution

Thanks Joe for your reply. How do I disable the default update task in EPO?

Dr

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 8

Re: McAfee Autoupdate

Jump to solution

It's in a fairly unusual location   It's part of the VirusScan policy: under User Interface policies, there's a checkbox for "Disable default autoupdate task schedule."

HTH -

Joe

SCtbe
Level 12
Report Inappropriate Content
Message 5 of 8

Re: McAfee Autoupdate

Jump to solution

Joe,

Can you explain why default autoupdate task can't be re-enabled? I know that this the way it wotks, but what is the technical limitation or restriction to implement this?

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 8

Re: McAfee Autoupdate

Jump to solution

I'm afraid I don't know

From an ePO point of view, everything is working OK - i.e. when you change the policy to enable the task again, the correct policy element is being changed and sent to the cliet machine. t's just that for some reason that change is not being enforced by the VSE installation on the client machine. I don't know whether that's as designed or not

You may get more luck asking on the Viruscan forum - I've asked my colleagues here who deal with VSE, and they don't know.

Sorry

Regards -

Joe

wwarren
Level 15
Report Inappropriate Content
Message 7 of 8

Re: McAfee Autoupdate

Jump to solution

The option is described "Disable default autoupdate task schedule". Check it, and the local update task on VSE will be disabled.

Unchecking it does not translate to "Enable default autoupdate task schedule".

Unchecking it translates to "do nothing". It would be a feature change (FMR) to modify the behavior such that the local update task becomes enabled again, in which case we would probably change the text too so it's more intuitive as to what it does.

Revamping the User Interface is sorely needed, in my opinion, as there are other equally ambiguous settings and that behave contrary to what I just explained!

Point being, if a setting needs clarification on its functionality then seek that clarification from Support - jumping to conclusions might lead to disappointment.

UI improvement is meant to be a focus in a future release (possibly 9.0).

William W. Warren | S.I.R.R. | Customer Success Group | McAfee
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 8 of 8

Re: McAfee Autoupdate

Jump to solution

Good to know - cheers William

Joe