Showing results for 
Search instead for 
Did you mean: 
Level 7

McAfee Agent will not uninstall

I am running into issues when trying to uninstall McAfee Agent versions and

I have a list of over 400 workstations in my domain that have these older versions of McAfee Agent and I am trying to script a way to uninstall these versions remotely using powershell, then reinstall with version I have successfully scripted this process for a large block of workstations, but still have an even larger block that it's not working for. I have even RDP'd directly into a few of the machines that where having an issue uninstalling the old versions of software and was not able to remove it manually through control panel or running my script as an admin on the machine.

Here is the line of powershell script that I am using for the uninstall process:

Invoke-Command -ComputerName $computer -ScriptBlock {Start-Process 'C:\Program Files (x86)\McAfee\Common Framework\FrmInst.exe '/forceuninstall' '/silent''}

I've also tried using this with no better results:

Invoke-Command -ComputerName $computer -ScriptBlock {Start-Process 'C:\Program Files (x86)\McAfee\Common Framework\FrmInst.exe '/remove=agent'}

I've tried running commands through Psexec which did nothing for me.

I notice that when looking at the running processes on the machine, FrmInst stays running and does not go away. Its as though it is stalled out and I notice that the physical and virtual memory counts for that process stay at exactly the same number and will not go away until I kill the msiexec process or restart the computer. Retrying the uninstall after reboot gave me the same results. I attached a picture of the dialog box that comes up when RDP'd into a workstation to run the powershell command or control panel uninstall options directly. The dialog box stays on "gathering required information..." and will not progress until a reboot or msiexec process is killed.

Please help me out as I have been working on this issue for over a month now! Thanks

0 Kudos
3 Replies
Level 10

Re: McAfee Agent will not uninstall


Did you try just to install new version over existing (with force parameter)?

framepkg.exe /install=agent /forceinstall



0 Kudos
Level 10

Re: McAfee Agent will not uninstall


* Try to upgrade the McAfee Agent instead of uninstalling.

* If the Endpoint machine is 32bit the uninstalling path may differ from Program files(x86) to Program files.

* Also there is option in McAfee ePO to uninstall the McAfee agent - Try to delete the machine entry from ePO console and select the option "" which will uninstall the McAfee agent in the client machine on the next ASCI and delete entry from console.

0 Kudos
Level 12

Re: McAfee Agent will not uninstall

Also, check your Access Protection logs and see if the uninstall is triggering anything.  If so, disable AP and try the uninstallation again.

0 Kudos