cancel
Showing results for 
Search instead for 
Did you mean: 

Master Repository Empty

Hello

I logged into my epo 4.5 conole to see that my DAT and Engine are not present.

I went to my master repository and noticed that it is empty. No packages there.
Yesterday the console told me that there is a threat that i have no protection for.
It was updating without any issue over the week up to yesterday.

I have installed enpoint protection two days ago and i dont know if that has corrupted anything.

I can connect to my http://.../core/config and the database connection is fine.

Can anyone help?

Thanks
7 Replies
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 8

RE: Master Repository Empty



This is usually a sign that the catalog.z file in the root of the master repo (..\DB\Software) has become damaged or is missing.
Is that file present?
Can you restore it from backup?
If you have any distributed repositories, there may be a valid copy in the root of the distributed repo - try renaming the copy in the master repo and copying in the version from the distributed repo...

HTH

Joe

RE: Master Repository Empty

Hi Joe!
Thanks for replying

C:\Program Files\McAfee\ePolicy Orchestrator\DB\Software\catalog.z is still there and present.

I should have a backup of that file from last night though i should try two nights ago.

I dont know about distributed repositories.

Should i rename the C:\Program Files\McAfee\ePolicy Orchestrator\DB\Software\catalog.z as catalog.old and retore the catalog.z from two nights ago?

Is there anything else I would need to restore?

Thanks again
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 8

RE: Master Repository Empty



That should be enough to start with - if all goes well you should be able to see the contents of the repository again. If you can, I would recommend immediately doing a pull task.

HTH -

Joe

tidy!

happy Joe you are a professional who knows your craft!

That sorted it out and i ran an update and I now have the latest DAT installed.
Thanks again!

The only thing that need worry me is if my install of Endpoint caused this corruption or if the SFDBBack (safeboot database backup i think) backup schedule locked the database/system causing the corruption.

Is there anything else i should look at on epo before i celebrate and enjoy the rest of my Friday?
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 8

RE: tidy!



I can't think of a reason off the top of my head why either of those operations would cause catalog.z to get bent... about the only additional check I would do is pick a test machine and make sure you can deploy software to it from the master repo, and that it can update itself from the master as well.

Then I'd head for the pub Smiley Happy

Joe

RE: tidy!

Nice! Deployed EPO to a new client and checked that the DAT has updated on existing client too.

I think ill get working on that pub visit you mentioned too.Smiley Very Happy

Thanks again

Re: RE: Master Repository Empty

My Master Repository is getting empty about every two weeks (ePO 4.5 on Windows 2008 with SQL Server Express 2008); I have to restart the server to get it back.

I've already posted a thread about this problem:

http://community.mcafee.com/thread/20146?tstart=0http://mcafee-ext.hosted.jivesoftware.com/message/105095

My catalog.z file is present in DB\Software but I don't know how to determine if it's corrupted (for example, WinRAR cannot open it)...

Any ideas?

Message was edited by: marek_g on 2/8/10 6:59:45 PM GMT+01:00