cancel
Showing results for 
Search instead for 
Did you mean: 

Log on to Orion Platform MFS (missing dependencies)

Hi Group,

I am having a recurring issue to which I thought I had the solution, but this time I am not able to fix the problem by "traditional means":

The ePO server rebooted this weekend due to some MS updates and showed the all-too-well-known screen with red errors down the page. I deleted all corrupt extensions from both the folder E:\Program Files (x86)\McAfee\ePolicyOrchestrator\Server\extensions\installed and the database table dbo.OrionExtensions, but I still get this screen:

ePO.jpg

When I log on with the admin account, I see this:

ePO2.jpg

There were 7 broken extensions, known by their one-line text in the extension.properties file (instead of multiple lines) but, they are all gone now.

Judging by the screenshot, done anyone have ideas as to what next steps I should try in order to fix this problem?

Thanks,

K

6 Replies

Re: Log on to Orion Platform MFS (missing dependencies)

Dear Kmcin11,

Have you changed any password(Domain or DB password) if the answer is no then try to restat all your McAfee ePO services and try to log-in into your console if still the problem exist try with config option

Type the url in browser HTTPS://<ePO_Server name or IP address>:8443/core/config

and verify your ePO server name batabase instance etc then click test connection after the successfull conection veriied click ok and reboot your ePO server then try to log in ....

Re: Log on to Orion Platform MFS (missing dependencies)

Hi Lakshmanan,

It is not a pw issue unfortunately. I have had those as well, but the red errors mention that in the bottom if it has to do with the pw. I didn't change the password and I have rebooted a few times, as well as restarted the services. I can log on to the console so the connection is there, but then I get the "unexpected error."

This here has to do with some extensions not functioning the way they should, but I can't figure out which ones may be the offender.

I have cleaned out all of the broken extensions from both the folder and the db table already, but still no luck.

Thanks,

Kelissa

Re: Log on to Orion Platform MFS (missing dependencies)

Dear Kmcin11,

aftrer perfom all the workaround  still your facing the same issue then kindly escalate to McAfee technical support...

Re: Log on to Orion Platform MFS (missing dependencies)

Hi Kelissa,

I have the same issue but i have fixed the red message that appeared when i open the ePO console.

When i logon, i have the same screen that you showed.

did you solve this issue? if so, what did you do to resolve it?

Thanks in advance.

Edward.

Re: Log on to Orion Platform MFS (missing dependencies)

Hi Edward,

I "fixed" this issue by completely rebuilding the ePO server.

I believe I know what was causing the issue: I was running ePO on a 2008 SP2 server. Since I was supposed to install Policy Auditor, I attempted to do just that, without realizing that the version DISA had put out there was not meant for Server 2008 but for 2003. In essense, I think this process corrupted the database to the point of no return.

Ever since I rebuilt I have had zero problems.

K

Re: Log on to Orion Platform MFS (missing dependencies)

Hi Kelissa,

Thanks for your help, but sincerely i hoped that there was a way to fix the ePO.

I also thought that the rebuilding was the solution but I wanted to find another way.

The reason you wrote in your answer, McAfee technical support helped you or you found it by yourself.

Thanks for you help and your time.

Edward