cancel
Showing results for 
Search instead for 
Did you mean: 
scoutt
Level 11
Report Inappropriate Content
Message 1 of 2

Invalid path on ePO server 4.0 patch 6

I am trying to find out why my agnts can't talk back to my ePO server and I thing I have found the problem. In the agent log I see this

The part I am worried about is this

Upload response target: C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack\pkg00129217888632500000_19231.spkg

That target is not on the ePO server as the server has 8.7i installed and that package changed the path to

C:\Documents and Settings\All Users\Application Data\Network Associates\Common Framework

How do I fix the path?

2010-06-23 10:47:43     I     #2552     Agent     Agent is sending FULL PROPERTIES
2010-06-23 10:47:43     I     #2552     Agent     Forwarding all events
2010-06-23 10:47:43     I     #1800     Agent     Started processing a package..
2010-06-23 10:47:43     I     #2552     Agent     ASCI is not done yet ...Please wait for ASCI!
2010-06-23 10:47:43     I     #1800     Agent     Preparing Props Package
2010-06-23 10:47:43     I     #1800     SpiPkgr     Using sequence number 72
2010-06-23 10:47:43     i     #1800     Agent     Agent communication session started
2010-06-23 10:47:43     i     #1800     Agent     Agent is sending FULL PROPS package ePO server
2010-06-23 10:47:43     i     #1800     Agent     Agent is connecting to ePO server
2010-06-23 10:47:43     I     #1800     naInet     HTTP Session initialized
2010-06-23 10:47:43     I     #1800     imsite          Upload from: C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack\pkg00129217888630310000_978.spkg
2010-06-23 10:47:43     I     #1800     imsite          Upload response target: C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack\pkg00129217888632500000_19231.spkg
2010-06-23 10:47:43     I     #1800     naInet     Uploading file C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack\pkg00129217888630310000_978.spkg to ePO Server...
2010-06-23 10:47:43     I     #1800     naInet     Connecting to Real Server: 10.10.10.27 on port: 80
2010-06-23 10:47:43     I     #1800     naInet     Connected to ePO Server: 10.10.10.27
2010-06-23 10:47:43     I     #1800     naInet     Uploading SPIPE HTTP header
2010-06-23 10:47:43     I     #1800     naInet     Uploading data in bytes: 8192
2010-06-23 10:47:43     I     #1800     naInet     Uploading data in bytes: 8192
2010-06-23 10:47:43     I     #1800     naInet     Uploading data in bytes: 1501
2010-06-23 10:47:43     I     #1800     naInet     Reading acknowledgement from ePO Server
2010-06-23 10:47:43     I     #1800     naInet     Received response [] from ePO Server
2010-06-23 10:47:43     I     #1800     naihttp     Failed to get acknowledgement from Server
2010-06-23 10:47:43     E     #1800     imsite     Error trace:
2010-06-23 10:47:43     E     #1800     imsite      [uploadFile,,/spipe/pkg?AgentGuid={40E3AACD-E501-4D18-973B-BD2CD53AC698}&Source=Agent_3.0.0,pkg00129217888630310000_978.spkg,C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack,C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack\pkg00129217888632500000_19231.spkg]->
2010-06-23 10:47:43     E     #1800     imsite       NaInet library returned code == -14
2010-06-23 10:47:43     E     #1800     imsite     Error trace:
2010-06-23 10:47:43     E     #1800     imsite      [uploadFile,,/spipe/pkg?AgentGuid={40E3AACD-E501-4D18-973B-BD2CD53AC698}&Source=Agent_3.0.0,pkg00129217888630310000_978.spkg,C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack,C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack\pkg00129217888632500000_19231.spkg]->
2010-06-23 10:47:43     E     #1800     imsite       NaInet library returned code == -14
2010-06-23 10:47:43     E     #1800     imsite     Error trace:
2010-06-23 10:47:43     E     #1800     imsite      [uploadFile,,/spipe/pkg?AgentGuid={40E3AACD-E501-4D18-973B-BD2CD53AC698}&Source=Agent_3.0.0,pkg00129217888630310000_978.spkg,C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack,C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack\pkg00129217888632500000_19231.spkg]->
2010-06-23 10:47:43     E     #1800     imsite       The naInet library returned an error. [Parent error: NaInet library returned code == -14]
2010-06-23 10:47:43     I     #1800     naInet     HTTP Session closed
2010-06-23 10:47:43     i     #1800     Agent     Failed to upload package to ePO Server
2010-06-23 10:47:43     i     #1800     Agent     Agent communication session closed
2010-06-23 10:47:43     I     #1800     Agent     Setting flag to force full properties on next ASCI
2010-06-23 10:47:43     I     #1800     Agent     Agent communication failed, result=-2404

1 Reply
scoutt
Level 11
Report Inappropriate Content
Message 2 of 2

Re: Invalid path on ePO server 4.0 patch 6

Nevermind, it seems I have fixed it. After updating to patch 6 it seems you can force install of agent now and it works. The agent was updated with the newest patch and version and now it communicates successfully. Before on patch 3 I was unable to force an update.