cancel
Showing results for 
Search instead for 
Did you mean: 

Integrating LinuxShield 1.5.1 with EPO v4

Having installed the agents and software on my Linux box, I discovered that I had copied the wrong srpubkey.bin, reqseckey.bin and SiteList.xml from the EPO server - the master repo information was not configured.

So I copied the files from the install folder of EPOAGENT3700LYNX on the EPO server to the linux box (/opt/McAfee/cma for bins and /opt/McAfee/cma/scratch/etc for xml and restarted the agent.

No when I login to the web console and select Repositories I get an alert "Received Invalid Repository List"

Is there anyway to correct this?

I've tried to uninstall the agent, but I get a "not installed" message back for either -e or -q.

If I try to reinstall rpm -ivh, it tells me it is already installed - so this is not an option.

Any help would be great.
1 Reply
Highlighted

RE: Integrating LinuxShield 1.5.1 with EPO v4

Hello butlert,

i have also installed McAfee on our Linux machines.
My installation way:

1. Share C:\Program Files\McAfee\ePolicy Orchestrator\DB\Software\Current\EPOAGENT3700LYNX\Install\0409 on epo server (for me Linux$)
2. mount -t cifs //eposerver/Linux$ /mnt/mcafee/ -o user=mcafee
3. rpm -ivh MFErt.i686.rpm
4. rpm -ivh MFEcma.i686.rpm

[root@linuxserver tmp]# rpm -ivh MFEcma.i686.rpm
Preparing... ########################################### [100%]
Available space : 992992 KB
Required size : 17408 KB
Stopping dependent services...
Signalling agent key regeneration
1:MFEcma ########################################### [100%]
Do you want to run in ePO managed mode? (Y/N)
y
Is your ePO server version less than 4.0? (Y/N)
n
*************************************************************
Please provide the absolute path of config dir which
contains the sitelist.xml,reqseckey.bin,srpubkey.bin.
Press any key to skip ,skipping this will not start the agent.
Please refer specs to start the agent after skipping.

Enter absolute path of config dir:
/mnt/mcafee
*********************************************************
Do you want to start the agent service? (Y/N)
Y

Registering the start up script...
Updating linker cache...
Going to start the mcafee agent
Starting McAfee Agent services... [ OK ]
Checking for dangling symlinks
Removing dangling link /opt/McAfee/cma/lib/libcryptocmerpm2.so
Deleting symbolic link /opt/McAfee/cma/bin/libcurl.so.3
Agent Successfully Installed

After this you can install or update your LinuxShield
rpm -U LinuxShield-1.5.1-260.i386.rpm

Thats all. Hope this will help.
Want to Ask a Question?

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community