cancel
Showing results for 
Search instead for 
Did you mean: 
jd_01
Level 7
Report Inappropriate Content
Message 1 of 3

Installing Epo4.6 agent Extension fault on EPO 4.0 (build:1363)

Jump to solution

Hi,

In preperation of upgrading our Epo 4.0(build1363) to Epo 4.6, I plan to upgrade all Epo agents first from 4.0 to 4.6sp1. For this I started installing the Epo agent4.6 Extention but get a error message during the install proces:

Unable to install extension. com.mcafee.orion.core.ext.ExtensionException: Installation error: setup: BUILD FAILED java.lang.NoSuchMethodError: com.mcafee.orion.core.OrionCore.getCoreBeanFactory()Lorg/springframework/beans/factory/ListableBeanFactory; Total time: 0 seconds

Any idea what this could be and how to work around this?

thx!

1 Solution

Accepted Solutions
hem
Level 15
Report Inappropriate Content
Message 2 of 3

Re: Installing Epo4.6 agent Extension fault on EPO 4.0 (build:1363)

Jump to solution

Are you trying to install MA 4.6 extensions on ePO 4.0? If then it's not supported #: https://kc.mcafee.com/corporate/index?page=content&id=KB51573.

2 Replies
hem
Level 15
Report Inappropriate Content
Message 2 of 3

Re: Installing Epo4.6 agent Extension fault on EPO 4.0 (build:1363)

Jump to solution

Are you trying to install MA 4.6 extensions on ePO 4.0? If then it's not supported #: https://kc.mcafee.com/corporate/index?page=content&id=KB51573.

jd_01
Level 7
Report Inappropriate Content
Message 3 of 3

Re: Installing Epo4.6 agent Extension fault on EPO 4.0 (build:1363)

Jump to solution

Thx Hem,

This would mean when I go for an 4.0 to 4.6 upgrade, I'm unable to upgrade my server park (1800 servers) step by step with the new 4.6 agent first?  As fare as I understand an Epo 4.6 upgrade means an auto upgrade of the the Agents on all server, without having any controle over it?

on 1/11/12 8:39:59 AM CST